Bug 1420036

Summary: Ability to create&manage workloads in between update/upgrade steps
Product: Red Hat OpenStack Reporter: Jaromir Coufal <jcoufal>
Component: openstack-tripleo-heat-templatesAssignee: Sofer Athlan-Guyot <sathlang>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: unspecified Docs Contact:
Priority: high    
Version: 11.0 (Ocata)CC: dbecker, mburns, morazi, rhel-osp-director-maint, sathlang
Target Milestone: rcKeywords: TestOnly, Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:57:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1437322    

Description Jaromir Coufal 2017-02-07 16:16:20 UTC
As a cloud operator I want to be able to have working API services for my cloud in between upgrade steps so that users of my cloud have minimal donwtime when they are not able to manipulate with their VMs.

Comment 2 Marius Cornea 2017-04-25 17:59:24 UTC
After major-upgrade-composable-steps.yaml I was able to spawn new instances/create networks/routers, reach instance via floating IP, create and attach volume.

After upgrading 1/2 compute nodes I was able to spawn new instances/create networks/routers, reach instance via floating IP, create and attach volume.

Comment 3 errata-xmlrpc 2017-05-17 19:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245