Bug 1433898

Summary: New package: Sushy
Product: [Community] RDO Reporter: Lucas Alvares Gomes <lmartins>
Component: Package ReviewAssignee: Matthias Runge <mrunge>
Status: CLOSED CURRENTRELEASE QA Contact: hguemar
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: trunkCC: apevec, dtantsur, hguemar, jpena, karlthered, mrunge, Smahmoud
Target Milestone: ---Flags: mrunge: rdo-review+
Target Release: trunk   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-12 14:37:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1427510    

Description Lucas Alvares Gomes 2017-03-20 10:40:50 UTC
Description of problem:

Sushy is a Python library to communicate with Redfish based systems (http://www.dmtf.org/standards/redfish) which is currently being used to create a "redfish" driver/hardware type for Ironic.

Additional info:

The official repository for the project is the https://github.com/openstack/sushy

Comment 2 Lucas Alvares Gomes 2017-03-21 17:09:38 UTC
The rdoinfo change: https://review.rdoproject.org/r/#/c/5897/

Comment 3 Alan Pevec 2017-03-21 23:03:20 UTC
Initial license check looks good, project is Apache v2.0 licensed:

sushy/.coveragerc: *No copyright* UNKNOWN
sushy/.gitreview: *No copyright* UNKNOWN
sushy/.mailmap: *No copyright* UNKNOWN
sushy/.testr.conf: *No copyright* UNKNOWN
sushy/CONTRIBUTING.rst: *No copyright* UNKNOWN
sushy/HACKING.rst: *No copyright* UNKNOWN
sushy/LICENSE: *No copyright* Apache (v2.0)
sushy/MANIFEST.in: *No copyright* UNKNOWN
sushy/README.rst: *No copyright* Apache
sushy/babel.cfg: *No copyright* UNKNOWN
sushy/requirements.txt: *No copyright* UNKNOWN
sushy/setup.cfg: *No copyright* Apache
sushy/setup.py: Apache (v2.0) GENERATED FILE
sushy/test-requirements.txt: *No copyright* UNKNOWN
sushy/tox.ini: *No copyright* UNKNOWN
sushy/sushy/__init__.py: *No copyright* Apache (v2.0)
sushy/sushy/connector.py: Apache (v2.0)
sushy/sushy/exceptions.py: Apache (v2.0)
sushy/sushy/main.py: Apache (v2.0)
sushy/sushy/utils.py: Apache (v2.0)
sushy/tools/mockup_server.py: Apache (v2.0)
sushy/doc/source/conf.py: *No copyright* Apache (v2.0)
sushy/doc/source/contributing.rst: *No copyright* UNKNOWN
sushy/doc/source/index.rst: *No copyright* UNKNOWN
sushy/doc/source/installation.rst: *No copyright* UNKNOWN
sushy/doc/source/readme.rst: *No copyright* UNKNOWN
sushy/doc/source/usage.rst: *No copyright* UNKNOWN
sushy/releasenotes/source/conf.py: *No copyright* Apache (v2.0) GENERATED FILE
sushy/releasenotes/source/index.rst: *No copyright* UNKNOWN
sushy/releasenotes/source/unreleased.rst: *No copyright* UNKNOWN
sushy/sushy/resources/base.py: Apache (v2.0)
sushy/tools/mockup_server_libvirt/mockup_server_libvirt.py: Apache (v2.0)
sushy/tools/mockup_server_libvirt/requirements.txt: *No copyright* UNKNOWN
sushy/sushy/resources/system/constants.py: Apache (v2.0)
sushy/sushy/resources/system/mappings.py: Apache (v2.0)
sushy/sushy/resources/system/system.py: Apache (v2.0)
sushy/sushy/tests/unit/base.py: Apache (v2.0)
sushy/sushy/tests/unit/test_connector.py: Apache (v2.0)
sushy/sushy/tests/unit/test_main.py: Apache (v2.0)
sushy/sushy/tests/unit/test_utils.py: Apache (v2.0)
sushy/tools/mockup_server_libvirt/templates/root.json: UNKNOWN
sushy/tools/mockup_server_libvirt/templates/system.json: *No copyright* UNKNOWN
sushy/tools/mockup_server_libvirt/templates/system_collection.json: UNKNOWN
sushy/sushy/tests/unit/json_samples/root.json: UNKNOWN
sushy/sushy/tests/unit/json_samples/system.json: *No copyright* UNKNOWN
sushy/sushy/tests/unit/json_samples/system_collection.json: UNKNOWN
sushy/sushy/tests/unit/resources/test_base.py: Apache (v2.0)
sushy/sushy/tests/unit/resources/system/test_system.py: Apache (v2.0)

Comment 4 Haïkel Guémar 2017-03-22 08:54:31 UTC
LGTM but please set min versions for pbr and six to 2.0.0 and 1.9.0

Comment 5 Lucas Alvares Gomes 2017-03-22 10:22:24 UTC
> LGTM but please set min versions for pbr and six to 2.0.0 and 1.9.0

Hi Haikel,

Done! Here's the files:

SPEC: https://raw.githubusercontent.com/umago/sushy-spec/master/python-sushy.spec

SRPM: https://github.com/umago/sushy-spec/raw/master/python-sushy-0.0.1-0.20170322101819.39f9db1.el7.centos.src.rpm(In reply to Haïkel Guémar from comment #4)

Comment 6 Lucas Alvares Gomes 2017-03-22 10:23:20 UTC
Ouch, sorry messeup with the copy & paste,

SRPM: https://github.com/umago/sushy-spec/raw/master/python-sushy-0.0.1-0.20170322101819.39f9db1.el7.centos.src.rpm

Comment 7 Matthias Runge 2017-03-23 11:42:17 UTC
I would expect something like
%if 0%{?fedora}
%global with_python3 1
%endif


on top of the spec file. Otherwise looks good to me.

Comment 9 Matthias Runge 2017-03-27 15:12:16 UTC
Sorry for nitpicking here, I couldn't find any reference, why this requires shadow-utils. There is no pre-section in the spec.

While you're at it, please change references to python-pbr etc. to be using python2-pbr (and other python2 packages as well).

I'd doubt, this package requires python3-git, if it doesn't require python2-git as well. It looks like git is required at compile time for pbr? Then there's no need for python[23]-git.

Comment 11 Matthias Runge 2017-04-07 06:49:04 UTC
Lucas, this one looks good to me now.

The source is ASL 2.0 licensed. You can go ahead now and import it into RDO. Thanks for your patience.

Comment 13 Dmitry Tantsur 2017-04-11 15:43:30 UTC
Matthias, hi! Do you plan on finishing the formal review? According to apevec there is some output from some tool missing.

Comment 14 Matthias Runge 2017-04-12 08:39:15 UTC
Is there a written documentation to require fedora-review output? Due to version specifics for rdo (xxx instead of a real version), rdo packages don't build in koji directly.

In my understanding, we should explicitly look at the licenses, which are fine here.

Comment 15 Alan Pevec 2017-04-12 12:01:08 UTC
Haikel, can you publish Mock configs using RDO Trunk repos which can be used with fedora-review tool?
Matthias, fedorea-review integration with review.rdoproject.org is planned, in the meantime formal review is nice to have as it makes further reviews down the productization line easier.