Bug 1435154

Summary: Unable to boot the F26 Alpha-1.2 ISO on a ppc64/ppc64le LPAR
Product: [Fedora] Fedora Reporter: Éric Fintzel <efintzel>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 26CC: cz172638, dan, gansalmon, gduarte, hannsj_uhl, ichavero, itamar, jonathan, kernel-maint, madhu.chinakonda, mchehab, menantea, normand
Target Milestone: ---Keywords: Patch
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-4.11.0-0.rc6.git0.1.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-07-27 13:13:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1411321    
Bug Blocks: 1071880, 1430827    

Description Éric Fintzel 2017-03-23 09:46:40 UTC
Description of problem:
I tried to install the Fedora-Server-dvd-ppc64le-26-Alpha-1.2.iso and Fedora-Server-dvd-ppc64-26-Alpha-1.2.iso files on a LPAR. But the installation does not start, a problem occurs during kernel boot.


How reproducible:
Boot the ISO file on a LPAR.


Actual results:
The GRUB menu appears, the Fedora Installation option is selected automatically, but during the kernel boot the following error (same for ppc64le or ppc64) occurred:
...
Detected machine type: 0000000000000101
command line: BOOT_IMAGE=/ppc/ppc64/vmlinuz ro
Max number of cores passed to firmware: 128 (NR_CPUS = 1024)
Calling ibm,client-architecture-support... done
memory layout at init:
  memory_limit : 0000000000000000 (16 MB aligned)
  alloc_bottom : 000000000ec80000
  alloc_top    : 0000000010000000
  alloc_top_hi : 0000000010000000
  rmo_top      : 0000000010000000
  ram_top      : 0000000010000000
instantiating rtas at 0x000000000eca0000... done
prom_hold_cpus: skipped
copying OF device tree...
Building dt strings...
Building dt structure...
No memory for flatten_device_tree (no room)
EXIT called ok
0 > 


Expected results:
Installation should start and run smoothly.


Additional info:
It seems this problem is related to bugs 1417244 and 1093163:
https://bugzilla.redhat.com/show_bug.cgi?id=1417244
https://bugzilla.redhat.com/show_bug.cgi?id=1093163

Comment 1 Michel Normand 2017-03-30 06:22:45 UTC
* I added this bug as blocker for f26 Alpha for PowerPC bug #1430827
* Do we keep this bug open ? or is it same problem as already tracked by https://bugzilla.redhat.com/show_bug.cgi?id=1411321
related to redhat 7.3 and rescue mode.

Comment 2 Éric Fintzel 2017-03-30 15:43:20 UTC
The problem is still present with the Alpha-1.7 ISOs. But playing with the compression of the initrd.img file embedded in the ppc64le ISO, I was able to boot on a LPAR and perform the installation.

Initial initrd.img file size: 48663908 bytes
Re-compressed file size: 44875647 bytes, -7,78% (using the "xz -9e --format=lzma" command for compression)

Maybe the compression of initrd.img could be tuned this way... until a more generic solution is provided (see bug #1411321).

Comment 3 Michel Normand 2017-04-06 14:15:45 UTC
FYI, the patch of bug #1411321 is upstream as per related https://bugzilla.redhat.com/show_bug.cgi?id=1411321#c27

who is supposed to pull it for f26 ?

Comment 4 Dan Horák 2017-04-06 14:20:55 UTC
I will a send a request to the fedora kernel list.

Comment 5 Éric Fintzel 2017-04-14 13:34:58 UTC
Tested with the Fedora-Server-dvd-ppc64le-26-20170413.n.0.iso image.
The problem still occurs with F26:
...
Preparing to boot Linux version 4.11.0-0.rc5.git0.1.fc26.ppc64le (mockbuild@buildvm-ppc64le-05.ppc.fedoraproject.org) (gcc version 7.0.1 20170309 (Red Hat 7.0.1-0.12) (GCC) ) #1 SMP Mon Apr 3 17:40:15 UTC 2017
Detected machine type: 0000000000000101
command line: BOOT_IMAGE=/ppc/ppc64/vmlinuz ro
Max number of cores passed to firmware: 128 (NR_CPUS = 1024)
Calling ibm,client-architecture-support... done
memory layout at init:
  memory_limit : 0000000000000000 (16 MB aligned)
  alloc_bottom : 000000000ec80000
  alloc_top    : 0000000010000000
  alloc_top_hi : 0000000010000000
  rmo_top      : 0000000010000000
  ram_top      : 0000000010000000
instantiating rtas at 0x000000000eca0000... done
prom_hold_cpus: skipped
copying OF device tree...
Building dt strings...
Building dt structure...
No memory for flatten_device_tree (no room)
EXIT called ok
0 >

Comment 6 Éric Fintzel 2017-04-14 13:39:34 UTC
Tested with the Fedora-Server-dvd-ppc64le-Rawhide-20170413.n.0.iso image.
The problem does not occurs with Rawhide:
...
Preparing to boot Linux version 4.11.0-0.rc6.git2.1.fc27.ppc64le (mockbuild@buildvm-ppc64le-05.ppc.fedoraproject.org) (gcc version 7.0.1 20170410 (Red Hat 7.0.1-0.14) (GCC) ) #1 SMP Wed Apr 12 14:56:20 UTC 2017
Detected machine type: 0000000000000101
command line: BOOT_IMAGE=/ppc/ppc64/vmlinuz ro
Max number of cores passed to firmware: 128 (NR_CPUS = 1024)
Calling ibm,client-architecture-support...-
Elapsed time since release of system processors: 31525 mins 15 secs

Welcome to the Fedora Rawhide installer!
...

The kernel is loaded, the installer starts and installation with Anaconda using VNC ends successfully. After restart the new installed Fedora boots until the prompt, and we can log in the system.

Comment 7 Dan Horák 2017-04-14 19:28:56 UTC
We want compose newer than Fedora-26-20170414.n.0, which should be the last with 4.11.0-0.rc5.git0.1.fc26.ppc64le kernel, the next will have kernel-4.11.0-0.rc6.git0.1.fc26 with the memory size fix.

Comment 8 Menanteau Guy 2017-04-21 13:54:48 UTC
I confirm Fedora-26-20170420.n.0 ppc64 and ppc64le isos with new kernel-4.11.0-0.rc6.git0.1.fc26 boot without any problem on LPAR now.

Comment 9 Dan Horák 2017-04-21 14:04:39 UTC
Thanks for verifying.