Bug 1417244 - LPAR: Could not allocate memory for RTAS - Unable to boot kernel from installation ISO
Summary: LPAR: Could not allocate memory for RTAS - Unable to boot kernel from install...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker 1434272
TreeView+ depends on / blocked
 
Reported: 2017-01-27 16:32 UTC by Éric Fintzel
Modified: 2019-01-09 12:54 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1434272 (view as bug list)
Environment:
Last Closed: 2017-07-31 13:16:36 UTC


Attachments (Terms of Use)

Description Éric Fintzel 2017-01-27 16:32:29 UTC
Trying to boot the Fedora-Rawhide-20170125.n.0 installation ISO on a ppc64le LPAR, I got following error message:
______________________________________________________________________

...

IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 4.10.0-0.rc5.git1.1.fc26.ppc64 (mockbuild@buildvm-ppc64-04.ppc.fedoraproject.org) (gcc version 6.3.1 20170118 (Red Hat 6.3.1-2) (GCC) ) #1 SMP Tue Jan 24 14:38:07 UTC 2017
Detected machine type: 0000000000000101
Max number of cores passed to firmware: 128 (NR_CPUS = 1024)
Calling ibm,client-architecture-support... done
command line: BOOT_IMAGE=/ppc/ppc64/vmlinuz ro
memory layout at init:
memory_limit : 0000000000000000 (16 MB aligned)
alloc_bottom : 000000000ffd0000
alloc_top : 0000000010000000
alloc_top_hi : 0000000010000000
rmo_top : 0000000010000000
ram_top : 0000000010000000
Could not allocate memory for RTAS
EXIT called ok
0 > 
______________________________________________________________________


Note the problem also occurs with ppc64.
I also tried the Fedora-Rawhide-20170120.n.0 ISO with the same issue.
But the Fedora-Rawhide-20170124.n.0 ISO is booting successfully.

Interestingly the initrd.img file is 44M when the ISO boot is failing, but only 43M when it boots with success.

The problem seems to correspond to bug https://bugzilla.redhat.com/show_bug.cgi?id=1093163 where comment #23 suspects a "not enough space" for the RTAS.

Comment 1 Josh Boyer 2017-01-30 09:32:27 UTC
IIRC, this happens when the initramfs is too large for the space the firmware has allocated for the total boot.  The only solution I'm aware of is to make the initramfs smaller.  (Or to have firmware that allocates more space, but that tends to never happen.)

Comment 2 Carlo Lunghi 2017-03-08 09:07:59 UTC
I'm working on System i partitioning as consultant from Computers Services and Technologies - CoST in Milan for the FBS spa Company.
Here some details that I got when trying to boot the RHEL_7_3_PPC64LE installation ISO on a ppc64le LPAR:

1) Hardware:  IBM i (S814 P8 - iOS 7.2  TR 4)
2) Partitioning Software: IBM Virtual Partition Manager (VPM) - HMC Console, not used
3) Partition 1: the Host i Partition
4) Partition 2: the Linux partition didefined as lab case
Visualizzazione configurazione partizione LINUX              
Sistema:   S216B3FW  
   Identificativo e nome partizione . . . . . . :  2    LINUX                   
   Numero di processori partizione. . . . . . . :  1                            
   Numero minimo/massimo di processori    . . . :  1   / 1                      
   Utilizzo lotto processori condivisi. . . . . :  No                           
   Dimensione memoria partizione (MB) . . . . . :  8192                         
   Dimensione minima/massima memoria (MB) . . . :  512      / 8192              
   Abilitaz. gestione carico di lavoro. . . . . :  No                           
   Identificativi Ethernet virtuale (1=S~ 2=No)                                 
     1   2   3   4                                                              
     1   2   2   2                                                              

......................

Visualizzazione descrittore di rete
......................
Coda messaggi server . . . . . . . :   *JOBLOG                             
  Libreria . . . . . . . . . . . . :                                       
Identificativo di lotto  . . . . . :   *BASE                               
  Id lotto di sistema  . . . . . . :   2                                   
Origine dell'IPL . . . . . . . . . :   *STMF                               
File di flusso IPL . . . . . . . . :   /home/catalogo/RHEL_7_3_PPC64LE             
                                                                           
Parametri IPL  . . . . . . . . . . :   VNC=1 vncpassword=pippo123          
........................
         
                                                                               
5) How to interact with RHEL software: telnet console

telnet 10.200.22.23 2301 

Immettere il numero di partizione della console:
2
LINUX: Immettere id utente dei programmi di manutenzione:
LL
LINUX: Immettere parola d'ordine dei programmi di manutenzione:
LINUX: Collegamento alla console in corso...
LINUX: Console collegata.

 
6) How to produce ipl of the Linux partition: from terminal, maintenance program
                           Gestione stato partizione                           
                                                           Sistema:   S216B3FW 
 Immettere le opzioni e premere Invio.                                         
   1=Accensione   3=Riavvio IPL   7=Speg. ritardato     8=Speg. immediato      
   9=Modalità normale   10=Modalità manuale                                    
   A=Origine A    B=Origine B     C=Origine C           D=Origine D            
                                                                               
      ID Nome               Orig.   Mod.                Codici                 
 Opz  partizione            IPL     IPL      Stato      riferimento            
        1         21-6B3FW  B       Normale  Attivo                            
        2         LINUX     B       Manuale  Disattivo              


7) output on the console:

IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM                         IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM    STARTING SOFTWARE    IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM       PLEASE WAIT...    IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM                         IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM
-
-> select language
-> select device where to load software
-> exit from maintenace program yes

..........

Welcome to the Red Hat Enterprise Linux 7.3 installer!
error: can't find command `load_video'.
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 3.10.0-327.el7.ppc64 (mockbuild@ppc-034.build.en
g.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP T
hu Oct 29 17:33:57 EDT 2015
Detected machine type: 0000000000000101
Max number of cores passed to firmware: 256 (NR_CPUS = 2048)
Calling ibm,client-architecture-support... done
command line: BOOT_IMAGE=/vmlinuz-0-rescue-3fc5a33a8eb54ba2883c30c006ffcfe8 root
=/dev/mapper/rhel_the--first-root ro crashkernel=auto rd.lvm.lv=rhel_the-first/r
oot rd.lvm.lv=rhel_the-first/swap
memory layout at init:
  memory_limit : 0000000000000000 (16 MB aligned)
  alloc_bottom : 000000000ee30000
  alloc_top    : 0000000010000000
  alloc_top_hi : 0000000010000000
  rmo_top      : 0000000010000000
  ram_top      : 0000000010000000
Could not allocate memory for RTAS
EXIT called ok
0 >        ok
------------------------------------------
This suggestion at console prompt

setenv real-base 2000000 
dev /packages/gui obe  (it causes the restart of lpar boot)

or this one

setenv load-base 0x2000000
reset-all  

did not provide any success.
------------------------------------------
The operations to update the Technological Refresh to TR6 and to enhance the firmware level are in progress.
------------------------------------------
Given the right time to organize myself I'm ready to reproduce the bug in some shared form.

Comment 3 Michel Normand 2017-03-30 06:29:57 UTC
I suggest to close this bug as duplicate of new bug #1435154
There is no reason to keep two bugs for same problem on Fedora.
BTW the comment #2 is about RHEL 7.3 not Fedora.

Comment 4 Michel Normand 2017-05-11 12:18:20 UTC
Eric why not to close this bug ?

Comment 5 Carlo Lunghi 2017-05-16 14:11:56 UTC
(In reply to Michel Normand from comment #4)
> Eric why not to close this bug ?

Dear friends,
really I don't understand if someone is waiting for an action by me, neither if the bug occurred in RHEL 7.3 on the 16th February is on the road for fixing.
Could anyone kindly give me any details so allowing me to report on my committing customer ?
Thanks and regards,
c.l.

Comment 6 Carlo Lunghi 2017-08-08 14:39:21 UTC
Dear Mr. Kaur Randhawa.

Thanks for the care you and the Red Hat staff are following our case. 
After the occurrence of the error on Feb 2017 we suspended the tests on the RHEL distribution installed on ppc64 and technical people were re-directed to other project activities.
Generally speaking I confirm that our company did not change the approach to this research line, and all of us think to complete experiencing RHEL for ppc64 on the logical partition defined on our iSystem in Power8 architecture.
Due to the availability of the new release RHEL 7.4 I think that the testing job can be re-planned and re-started, probably soon, surely after the vacation time.
I will inform you, the RHEL staff and the community about our results keeping upgraded the case #01795762 .

Best regards,
Massimo Riccardi


Note You need to log in before you can comment on or make changes to this bug.