Bug 1443006

Summary: OpenDaylight deployment fails - OpenDayLightConnectionProtocol) was not provided
Product: Red Hat OpenStack Reporter: Itzik Brown <itbrown>
Component: openstack-tripleo-heat-templatesAssignee: Emilien Macchi <emacchi>
Status: CLOSED ERRATA QA Contact: Itzik Brown <itbrown>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 11.0 (Ocata)CC: jschluet, lpeer, mburns, rhel-osp-director-maint
Target Milestone: rc   
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-6.0.0-7.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
N/A
Last Closed: 2017-05-17 20:22:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Itzik Brown 2017-04-18 09:36:36 UTC
Description of problem:

When deploying OpenDaylight the deployment fails with the error:
[overcloud]: CREATE_FAILED Resource CREATE failed: Error in ControllerServiceChain output role_data: Error in 74 output role_data: The Parameter (OpenDayLightConnectionProtocol) was not provided.

There is a typo in puppet/services/opendaylight-api.yaml

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-5.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Itzik Brown 2017-04-23 04:44:39 UTC
Fix was merged to u/s Ocata.

Comment 5 Itzik Brown 2017-04-25 03:37:22 UTC
Checked with:
openstack-tripleo-heat-templates-6.0.0-7.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 20:22:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245