Bug 1443006 - OpenDaylight deployment fails - OpenDayLightConnectionProtocol) was not provided
Summary: OpenDaylight deployment fails - OpenDayLightConnectionProtocol) was not provided
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Emilien Macchi
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-18 09:36 UTC by Itzik Brown
Modified: 2018-10-18 07:20 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-05-17 20:22:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 457541 None None None 2017-04-18 09:36:35 UTC

Description Itzik Brown 2017-04-18 09:36:36 UTC
Description of problem:

When deploying OpenDaylight the deployment fails with the error:
[overcloud]: CREATE_FAILED Resource CREATE failed: Error in ControllerServiceChain output role_data: Error in 74 output role_data: The Parameter (OpenDayLightConnectionProtocol) was not provided.

There is a typo in puppet/services/opendaylight-api.yaml

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-5.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Itzik Brown 2017-04-23 04:44:39 UTC
Fix was merged to u/s Ocata.

Comment 5 Itzik Brown 2017-04-25 03:37:22 UTC
Checked with:
openstack-tripleo-heat-templates-6.0.0-7.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 20:22:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.