Bug 1444

Summary: kerneld failure.
Product: [Retired] Red Hat Linux Reporter: Harvey Stein <hjstein>
Component: modutilsAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-08 19:18:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Harvey Stein 1999-03-07 09:00:10 UTC
I noticed after building kernel 2.2.2 that modules were
no longer autoloading.  I didn't notice with 2.2.0-pre9
(aka 2.2.0-final) because I inadvertently compiled in kmod,
and kmod seems to be fine.  In 2.2.2 I tried to use kerneld
(& didn't include kmod in the kernel) and modules wouldn't
autoload.  This might be a bug, or it might be because of
the module vs modutils clash which I reported separately.
I haven't tried cleaning it up & trying again yet.

Comment 1 Bill Nottingham 1999-03-08 19:18:59 UTC
kerneld doesn't work with 2.2 kernels.
If you want autoloading, use kmod,