Bug 1448923

Summary: Xfce ARM image default browser is unavailable (image fails to build)
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: firefoxAssignee: Martin Stransky <stransky>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 26CC: gecko-bugs-nobody, jhorak, kengert, kevin, mruckman, pbrobinson, pjasicek, pwhalen, robatino, stransky, vpavlin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: firefox-53.0.2-5.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-19 18:26:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418, 1349186    

Description Adam Williamson 2017-05-08 16:36:04 UTC
Firefox 53 fails to build on ARM, and rather than fixing this before shipping it to Fedora 26 (and Rawhide), the Firefox maintainers built it and shipped it with non-x86 arches disabled:

https://koji.fedoraproject.org/koji/buildinfo?buildID=881358
https://bodhi.fedoraproject.org/updates/FEDORA-2017-8285bc54d9

This means Xfce ARM (and probably other ARM images, but Xfce ARM is a release-blocking image) fails to compose, and also that it has no default browser.

There are two possible resolutions to this: fix Firefox to build on ARM, or change Xfce's default browser to something that *is* available on ARM. Obviously we would highly prefer the first solution.

Comment 1 Adam Williamson 2017-05-08 16:52:35 UTC
Proposing as a Beta blocker (as an alternative to blocking on https://bugzilla.redhat.com/show_bug.cgi?id=1443938 directly), violates the Alpha criteria "All release-blocking images must boot in their supported configurations" (since a blocking image is missing for now) and "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments" (just removing Firefox from the package set would not be a sufficient fix).

Comment 2 Mike Ruckman 2017-05-12 21:18:41 UTC
Discussed in the 2017-05-02 Blocker Review meeting [0]. This is accepted as a blocker in lieu of #1443928 because this more precisely reflects the actual criteria violation. There was a long discussion on it during the meeting [1] as well as a mailing list discussion [2] to explain the rationale.

[0] Sorry for the late update on this.
[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-05-08/f26-blocker-review.2017-05-08-16.00.log.html
[2] https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/NNKH7V7S6XV673EG5YBQCG2MBO6LCUKP/

Comment 3 Mike Ruckman 2017-05-12 21:19:38 UTC
The actual text of the #AGREED is: "This bug is a conditional violation of the following criterion: "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments." as well as the "image compose" criterion."

Comment 4 Stephen Gallagher 2017-05-17 12:42:51 UTC
Firefox was patched to support the armv7hl architecture.

Comment 5 Adam Williamson 2017-05-19 18:26:46 UTC
This appears to be resolved now; the update has been pushed stable and we have Xfce ARM images again in current composes. I haven't had direct confirmation that Firefox *works* properly, but if there are any problems there, they can be reported separately. Thanks for the build fix!