Bug 1455585

Summary: Push devassistant update to support Python 3.6 on fedora 26
Product: [Fedora] Fedora Reporter: Julien Enselme <jujens>
Component: devassistantAssignee: Bohuslav "Slavek" Kabrda <bkabrda>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: awilliam, bkabrda, jujens, mhroncok, phracek, tradej
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-07-07 22:56:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Julien Enselme 2017-05-25 14:05:27 UTC
Hi,

I trying to update to fedora 26 alpha and the update fails due to:

package devassistant-dap-c-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-cpp-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-nodejs-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-perl-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-php-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-python-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-ruby-0.11-3.fc24.noarch requires devassistant-dap-vim, but none of the providers can be installed.
package devassistant-dap-devassistant-0.11-3.fc24.noarch requires devassistant-dap-python, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed.
package devassistant-dap-custom-0.10.0-9.fc24.noarch requires devassistant-dap-github, but none of the providers can be installed.
package devassistant-dap-dap-1.3-3.fc24.noarch requires devassistant-dap-github, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed.
package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed

I think  the main problem is package devassistant-gui-0.11.2-7.fc25.noarch requires python(abi) = 3.5, but none of the providers can be installed. From what I see on koji, it was rebuild for Python 3.6 (https://koji.fedoraproject.org/koji/buildinfo?buildID=841778). But in bodhi, it looks the update was never pushed (https://bodhi.fedoraproject.org/updates/?packages=devassistant). So I guess it was build after the version was branched. Can you push the update?

Comment 1 fednuc 2017-06-16 20:37:17 UTC
bkabrda, can you make a declaration of intent on this (will/won't be fixed)? Still missing with F26 beta now out (like Julien I noticed it's the only package set that is missing when trying to upgrade, causing an --allowerasing upgrade requirement).

Comment 2 Tomas Radej 2017-06-19 08:29:06 UTC
Stephen, Bohuslav no longer works on the project. Adding Miro Hroncok, the current maintainer, to needinfo. The project is basically dead now, so I would expect the negative answer.

Comment 3 Miro Hrončok 2017-06-19 16:01:12 UTC
Devassistant was entirely removed as a dead project from Fedora 26+.

Does this break the update from F25 or F24 to F26?

Comment 4 fednuc 2017-06-19 17:14:32 UTC
F25->F26, breaks system-upgrade unless --allowerasing is used.

Comment 5 Miro Hrončok 2017-06-19 18:56:46 UTC
Honestly, I have no idea how to deal with that.

Maybe Adam can advise here?

Comment 6 Julien Enselme 2017-06-19 19:11:34 UTC
As Stephen said, you need to use --allowerasing or uninstall devassistant first. No a big deal but it is annoying. And you don't know why devassistant is not available.

I had no idea devassistant was retired as a dead package. Maybe we need a way to handle this within the upgrade procedure.

Comment 7 fednuc 2017-06-19 21:37:17 UTC
There's no fundamental F26 package that can be set to obsolete devassistant? Or some new hotness package (Builder??) maybe to do the same? Or is that too hacky/slightly abusive of the obsoletes mechanism?

Comment 8 Adam Williamson 2017-06-20 17:40:18 UTC
Yes, there is: it's called fedora-obsolete-packages . You can file a bug on fedora-obsolete-packages , requesting that it add an Obsoletes for devassistant (and any subpackages, of course).

Comment 9 fednuc 2017-06-20 20:32:46 UTC
Filed: https://bugzilla.redhat.com/show_bug.cgi?id=1463408

Miro, can you check the package list there?

Comment 10 Fedora Update System 2017-06-22 08:05:50 UTC
fedora-obsolete-packages-26-3 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7ac24368c6

Comment 11 Fedora Update System 2017-06-23 06:24:50 UTC
fedora-obsolete-packages-26-3 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7ac24368c6

Comment 12 Fedora Update System 2017-07-07 22:56:50 UTC
fedora-obsolete-packages-26-3 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.