Bug 1463408 - Obsolete devassistant
Obsolete devassistant
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 16:22 EDT by Stephen
Modified: 2017-07-07 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: fedora-obsolete-packages-26-3
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-07 18:56:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jason Tibbitts 2017-06-20 16:30:14 EDT
Please follow https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages

Specifically, the following:

"Please include information on which packages need to be obsoleted, the exact versions which need to be obsoleted, and the reasons why they cannot be allowed to remain installed."
Comment 2 Stephen 2017-06-20 16:40:25 EDT
Per the linked bug, there are no F26 packages for devassistant, Miro (the current maintainer according to Tomas Radej), has said:

"Devassistant was entirely removed as a dead project from Fedora 26+."

Fedora 25 devassistant packages:

devassistant
devassistant-cli
devassistant-core
devassistant-devel
devassistant-gui
python3-dapp

Additional Fedora 24 devassistant packages that linger after a F24 -> F25 upgrade and have to be uninstalled if present to complete a F25 -> F26 upgrade:

devassistant-dap-c
devassistant-dap-common_args
devassistant-dap-cpp
devassistant-dap-custom
devassistant-dap-dap
devassistant-dap-devassistant
devassistant-dap-docker
devassistant-dap-eclipse
devassistant-dap-git
devassistant-dap-github
devassistant-dap-java
devassistant-dap-nodejs
devassistant-dap-perl
devassistant-dap-php
devassistant-dap-python
devassistant-dap-ruby
devassistant-dap-tito
devassistant-dap-vim

I can provide the exact versions that were uninstalled at the specific time I upgraded to F26, but I'm not sure that makes sense, since there may be upgraders who have older/newer versions.
Comment 3 Jason Tibbitts 2017-06-20 16:45:29 EDT
Linking to another ticket is not sufficient.  I need to have everything documented here before I can proceed, including the versions of the various packages which need to be obsoleted.  One of the maintainers of the now-obsolete packages should provide that information.
Comment 4 Stephen 2017-06-20 17:27:15 EDT
> One of the maintainers of the now-obsolete packages should provide that information.

Yep, absolutely, I agree. NEEDINFO-ing him and bowing out entirely.

> including the versions of the various packages which need to be obsoleted

Should be versionless AFAICS ("Obsoletes: devassistant" etc.) since F26 won't satisfy any version's dependencies, but I'll let $other_people work that out :)
Comment 5 Jason Tibbitts 2017-06-20 17:32:16 EDT
Versionless obsoletes are not permitted and in any case will never be used in fedora-obsolete-packages.

None of us can predict the future.  The package could potentially return, and if the Obsoletes: are done properly this will not cause any issues.
Comment 6 Miro Hrončok 2017-06-21 03:46:28 EDT
Hi. I have retired all those packages. Please note that obsoleting them from fedora-obsolete-package was not mentioned at all at [1] and since it probably has to be done, I think the information should be presented there.

I don't intend to bump this in Fedora 24 or 25, so if noone does anything crazy, the following list with version-release should work fine:


Obsoletes: dap2rpm <= 0.1.11-4
Obsoletes: devassistant-cli <= 0.11.2-7
Obsoletes: devassistant-core <= 0.11.2-7
Obsoletes: devassistant-dap-common_args <= 0.10.0-9
Obsoletes: devassistant-dap-cpp <= 0.11-3
Obsoletes: devassistant-dap-custom <= 0.10.0-9
Obsoletes: devassistant-dap-c <= 0.11-3
Obsoletes: devassistant-dap-dap-1.3-3
Obsoletes: devassistant-dap-devassistant <= 0.11-3
Obsoletes: devassistant-dap-docker <= 0.11-3
Obsoletes: devassistant-dap-eclipse <= 0.10.0dev-10
Obsoletes: devassistant-dap-github <= 0.10.1-9
Obsoletes: devassistant-dap-git <= 0.11-3
Obsoletes: devassistant-dap-java <= 0.11.1-3
Obsoletes: devassistant-dap-nodejs <= 0.11-3
Obsoletes: devassistant-dap-openscad <= 0.0.3-3
Obsoletes: devassistant-dap-perl <= 0.11-3
Obsoletes: devassistant-dap-php <= 0.11-3
Obsoletes: devassistant-dap-python <= 0.11-3
Obsoletes: devassistant-dap-ruby <= 0.11-3
Obsoletes: devassistant-dap-tito <= 0.10.0dev-8
Obsoletes: devassistant-dap-vim <= 0.10.0dev-8
Obsoletes: devassistant-devel <= 0.11.2-7
Obsoletes: devassistant-gui <= 0.11.2-7
Obsoletes: devassistant <= 0.11.2-7
Obsoletes: python-dapp <= 0.3.0-5
Obsoletes: python-dap2rpm <= 0.1.11-4
Obsoletes: python3-dapp <= 0.3.0-5
Obsoletes: python3-dap2rpm <= 0.1.11-4



[1] https://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life
Comment 7 Jason Tibbitts 2017-06-21 10:18:20 EDT
I added a reference to the wiki page.

I will add the above obsoletes to fedora-obsolete-packages for F26 and rawhide.
Comment 8 Stephen 2017-06-21 10:48:47 EDT
> I added a reference to the wiki page.

Can I suggest adding something like "for example, if the packages' dependencies will no longer be satisfied" to highlight the necessity in that case?
Comment 9 Jason Tibbitts 2017-06-21 10:55:19 EDT
I don't honestly know what the various update methods will have issues with.  I just want to keep the set of obsoletes in this package down to the absolute minimum.

The page is open for editing to all cla/fpca+1 contributors so if you want to go into detail and are certain that those details are correct then feel free.
Comment 10 Stephen 2017-06-21 11:30:51 EDT
I'm not an anything ;)

I'm not 100% sure about it, I just originally saw that F25->F26 upgrade (via dnf) threw errors about devassistant (because of no-longer-satisfied Python dependencies) so there seems there might be a missing signpost for preventing that (e.g. via devassistant) - hence Miro pointing out that it wasn't documented.

The thought behind it was just avoiding the same thing in future.
Comment 11 Fedora Update System 2017-06-21 17:17:39 EDT
fedora-obsolete-packages-26-3 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7ac24368c6
Comment 12 Fedora Update System 2017-06-23 02:24:46 EDT
fedora-obsolete-packages-26-3 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7ac24368c6
Comment 13 Fedora Blocker Bugs Application 2017-06-29 13:29:18 EDT
Proposed as a Freeze Exception for 26-final by Fedora user tibbs using the blocker tracking app because:

 Again I was away and wasn't able to push a pending update.

An update to fedora-obsolete-packages is required to avoid dependency issues with the devassistant package which may prevent users from being able to update from F24/F25 to F26.
Comment 14 Adam Williamson 2017-06-29 15:36:19 EDT
Discussed at 2017-06-29 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-06-29/f26-blocker-review.2017-06-29-16.00.html . Rejected as a freeze exception issue, we think just pushing this as a 0-day update would be fine. It's easy enough for folks who want to upgrade early to use --allowerasing , or remove devassistant manually first.
Comment 15 Fedora Update System 2017-07-07 18:56:46 EDT
fedora-obsolete-packages-26-3 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.