Bug 1463658

Summary: eigen3 needs version update
Product: [Fedora] Fedora EPEL Reporter: Menanteau Guy <menantea>
Component: eigen3Assignee: Rich Mattes <richmattes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: c.david86, richmattes, skumari, taylor
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
Whiteboard:
Fixed In Version: eigen3-3.3.4-6.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-18 07:22:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1197165    

Description Menanteau Guy 2017-06-21 12:30:34 UTC
ceres-solver-1.12.0-2.el7 is failing on ppc64/ppc64le arches with a segfault on covariance_test. I suspected eigen3 to be the cause of the problem.
eigen3 current version in epel7 is eigen3-3.2.5-2.el7

eigen3 have been updated on fedora to eigen3-3.3.4-1.fc26.
When I build ceres-solver for epel7 with this last eigen3 version, ceres-solver builds successfully.

Please, could you consider to update eigen3 version for epel7.
koji build of eigen3-3.3.4-1.el7 is succesfull, 
see: https://koji.fedoraproject.org/koji/taskinfo?taskID=20075706

Comment 1 Peter Robinson 2018-05-26 17:33:28 UTC
*** Bug 1289737 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2018-05-26 22:11:01 UTC
eigen3-3.3.4-6.el7 ceres-solver-1.12.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-356e28b1f2

Comment 3 Fedora Update System 2018-05-27 20:24:32 UTC
ceres-solver-1.12.0-2.el7, eigen3-3.3.4-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-356e28b1f2

Comment 4 Fedora Update System 2018-09-18 07:22:24 UTC
ceres-solver-1.12.0-2.el7, eigen3-3.3.4-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.