Bug 1289737 - eigen3 rebuild fails on epel7
Summary: eigen3 rebuild fails on epel7
Keywords:
Status: CLOSED DUPLICATE of bug 1463658
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: eigen3
Version: epel7
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7ppc64le
TreeView+ depends on / blocked
 
Reported: 2015-12-08 20:43 UTC by Sinny Kumari
Modified: 2018-05-26 17:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-26 17:33:28 UTC


Attachments (Terms of Use)

Description Sinny Kumari 2015-12-08 20:43:09 UTC
Description of problem:
eigen 3.2.5 fails to build on epel7, ppc64le because of segfault in building doc.
Build log error message says:
/bin/sh: line 1: 14899 Segmentation fault      (core dumped) ./Tutorial_sparse_example /builddir/build/BUILD/eigen-eigen-bdd17ee3b1b3/ppc64le-redhat-linux-gnu/doc/special_examples/../html/Tutorial_sparse_example.jpeg
make[3]: *** [doc/special_examples/Tutorial_sparse_example] Error 139

After tracing back the problem, it appears that method dest.innerIndexPtr() from file SparseSelfAdjointView.h (https://bitbucket.org/eigen/eigen/src/ae97469d4c0baed422f112a9cd43399d515e4228/Eigen/src/SparseCore/SparseSelfAdjointView.h?at=3.2&fileviewer=file-view-default#SparseSelfAdjointView.h-382) returns null pointer.

Koji build - http://koji.fedoraproject.org/koji/taskinfo?taskID=12081762

Comment 1 Peter Robinson 2018-05-26 17:33:28 UTC

*** This bug has been marked as a duplicate of bug 1463658 ***


Note You need to log in before you can comment on or make changes to this bug.