Bug 1464404

Summary: logger: log (null) while trying to print volume name
Product: [Red Hat Storage] Red Hat Gluster Storage Reporter: Prasanna Kumar Kalever <prasanna.kalever>
Component: gluster-blockAssignee: Prasanna Kumar Kalever <prasanna.kalever>
Status: CLOSED ERRATA QA Contact: Sweta Anandpara <sanandpa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rhgs-3.3CC: rhs-bugs, sanandpa
Target Milestone: ---   
Target Release: RHGS 3.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gluster-block-0.2.1-2.el7rhgs Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-21 04:20:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1417151    

Description Prasanna Kumar Kalever 2017-06-23 11:12:22 UTC
Description of problem:
fix (null) prints in the log file, while trying to log a volume name

Comment 6 Sweta Anandpara 2017-07-03 12:02:47 UTC
Tested and verified this on the build gluster-block-0.2.1-3.el7rhgs.x86_64 and glusterfs-3.8.4-31.el7rhgs.x86_64

Any block creation if fails, it logs the error message in the log file with the volume name. No messages with 'null' as volume name were seen in the log files.

Moving this to verified in 3.3. Logs pasted below.

[2017-07-03 11:19:05.342098] INFO: create cli request, volume=ozone blockname=testblock3 mpath=2 blockhosts=10.70.47.121,10.70.47.113 authmode=0 size=53687091200 [at block_svc_routines.c+1722 :<block_create_cli_1_svc>]
[2017-07-03 11:49:09.214215] ERROR: failed while creating block file in gluster volume volume: ozone host: 10.70.47.121,10.70.47.113 [at block_svc_routines.c+1787 :<block_create_cli_1_svc>]
[2017-07-03 11:49:09.222956] INFO: create cli request, volume=ozone blockname=testblock4 mpath=2 blockhosts=10.70.47.121,10.70.47.113 authmode=0 size=1073741824 [at block_svc_routines.c+1722 :<block_create_cli_1_svc>]


[2017-06-29 07:16:33.728818] ERROR: glusterBlockVolumeInit(testvol) failed [at block_svc_routines.c+2527 :<block_list_cli_1_svc>]
[2017-06-29 07:40:50.327153] INFO: create request, volume=ozone blockname=testblock blockhosts=10.70.47.121,10.70.47.113,10.70.47.114 filename=1c8d90c6-f4fd-4902-848e-a847bb8635c4 authmode=1 passwd=ea2cbe3f-5d98-4e67-8696-5893371dff6e size=21474836480 [at block_svc_routines.c+1947 :<block_create_1_svc>]
[2017-06-29 07:40:56.780496] INFO: command exit code, 0 [at block_svc_routines.c+2076 :<block_create_1_svc>]

Comment 8 errata-xmlrpc 2017-09-21 04:20:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2773