Bug 1464404 - logger: log (null) while trying to print volume name
logger: log (null) while trying to print volume name
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Prasanna Kumar Kalever
Sweta Anandpara
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-23 07:12 EDT by Prasanna Kumar Kalever
Modified: 2017-09-21 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: gluster-block-0.2.1-2.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:20:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanna Kumar Kalever 2017-06-23 07:12:22 EDT
Description of problem:
fix (null) prints in the log file, while trying to log a volume name
Comment 6 Sweta Anandpara 2017-07-03 08:02:47 EDT
Tested and verified this on the build gluster-block-0.2.1-3.el7rhgs.x86_64 and glusterfs-3.8.4-31.el7rhgs.x86_64

Any block creation if fails, it logs the error message in the log file with the volume name. No messages with 'null' as volume name were seen in the log files.

Moving this to verified in 3.3. Logs pasted below.

[2017-07-03 11:19:05.342098] INFO: create cli request, volume=ozone blockname=testblock3 mpath=2 blockhosts=10.70.47.121,10.70.47.113 authmode=0 size=53687091200 [at block_svc_routines.c+1722 :<block_create_cli_1_svc>]
[2017-07-03 11:49:09.214215] ERROR: failed while creating block file in gluster volume volume: ozone host: 10.70.47.121,10.70.47.113 [at block_svc_routines.c+1787 :<block_create_cli_1_svc>]
[2017-07-03 11:49:09.222956] INFO: create cli request, volume=ozone blockname=testblock4 mpath=2 blockhosts=10.70.47.121,10.70.47.113 authmode=0 size=1073741824 [at block_svc_routines.c+1722 :<block_create_cli_1_svc>]


[2017-06-29 07:16:33.728818] ERROR: glusterBlockVolumeInit(testvol) failed [at block_svc_routines.c+2527 :<block_list_cli_1_svc>]
[2017-06-29 07:40:50.327153] INFO: create request, volume=ozone blockname=testblock blockhosts=10.70.47.121,10.70.47.113,10.70.47.114 filename=1c8d90c6-f4fd-4902-848e-a847bb8635c4 authmode=1 passwd=ea2cbe3f-5d98-4e67-8696-5893371dff6e size=21474836480 [at block_svc_routines.c+1947 :<block_create_1_svc>]
[2017-06-29 07:40:56.780496] INFO: command exit code, 0 [at block_svc_routines.c+2076 :<block_create_1_svc>]
Comment 8 errata-xmlrpc 2017-09-21 00:20:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2773

Note You need to log in before you can comment on or make changes to this bug.