Bug 1468348

Summary: [RFE] Offline Certificate Renewal System
Product: Red Hat Enterprise Linux 7 Reporter: Matthew Harmsen <mharmsen>
Component: pki-coreAssignee: Dinesh Prasanth <dmoluguw>
Status: CLOSED ERRATA QA Contact: ipa-qe <ipa-qe>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 7.4CC: alee, arubin, cfu, cheimes, cpelland, edewata, ftweedal, jmagne, ksiddiqu, mharmsen, mrhodes, myusuf, ndehadra, nkinder, tmihinto, tscherf, wburrows
Target Milestone: rcKeywords: FutureFeature, TestCaseProvided
Target Release: 7.7Flags: dmoluguw: needinfo+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: pki-core-10.5.16-1.el7 Doc Type: No Doc Update
Doc Text:
This tool must be documented in IPA -> See BZ#1690191.
Story Points: ---
Clone Of:
: 1669257 1690191 1696849 (view as bug list) Environment:
Last Closed: 2019-08-06 13:07:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1644708, 1696849, 1472344, 1550132, 1647919, 1669257, 1690191    

Description Matthew Harmsen 2017-07-06 19:09:52 UTC
Current scenario:

    When system certificate expires, we need to rollback date to a valid range   
    and start the renewal process.

Proposed Solution:

    An offline tool which creates temporary certificates to bring up the server
    and using which we can proceed with online renewal process.

Related wiki:

    * http://pki.fedoraproject.org/wiki/Offline_System_Certificate_Renewal

Comment 3 Matthew Harmsen 2017-08-31 18:15:59 UTC
*** Bug 1372378 has been marked as a duplicate of this bug. ***

Comment 4 Matthew Harmsen 2017-09-26 17:32:44 UTC
*** Bug 1474986 has been marked as a duplicate of this bug. ***

Comment 6 Matthew Harmsen 2017-10-25 16:33:04 UTC
[20171025] - RHEL 7.5 / RHCS 9.3 pre-Alpha Offline Triage ==> 7.6

Comment 9 Matthew Harmsen 2018-05-05 00:18:43 UTC
Per RHEL 7.5.z/7.6/8.0 Triage:  7.6 (RPL Candidate)

Comment 12 Fraser Tweedale 2019-03-18 04:55:40 UTC
How to test: https://github.com/dogtagpki/pki/pull/183#issue-261388269

Comment 17 Mohammad Rizwan 2019-05-16 06:29:54 UTC
Identified tier1 test passed. Based on observation in comment#16, marking the bug verified.

Comment 19 errata-xmlrpc 2019-08-06 13:07:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2228