Bug 1474986 - [RFE] Tool needed to renew expired system certificates
[RFE] Tool needed to renew expired system certificates
Status: CLOSED DUPLICATE of bug 1468348
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Dinesh Prasanth
Asha Akkiangady
: FutureFeature
Depends On:
Blocks: 1472344
  Show dependency treegraph
 
Reported: 2017-07-25 14:46 EDT by Ade Lee
Modified: 2017-09-26 13:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-26 13:32:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Lee 2017-07-25 14:46:56 EDT
Description of problem:

Currently, the only way to recover a certificate system instance whose certs have expired is by backdating the server till when the certs are not yet expired, and using the regular cert enrollment tools to renew the cert.  This process is manual and error prone.

A tool is needed to simplify and automate this process, without requiring the system to be backdated.  This tool would be part of the pki-server admin tool that would be run by a priviledged user on the server.

This tool could then be invoked by IPA administrators to easily resurrect certificate server instances.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Endi Sukma Dewata 2017-09-22 13:55:43 EDT
This seems to be a duplicate of bug #1468348.
Comment 3 Matthew Harmsen 2017-09-26 13:32:44 EDT

*** This bug has been marked as a duplicate of bug 1468348 ***

Note You need to log in before you can comment on or make changes to this bug.