Bug 1479673

Summary: [rbd-mirror] - Unable to write data on the promoted image from secondary rbd host
Product: Red Hat Ceph Storage Reporter: Harish NV Rao <hnallurv>
Component: RBD-MirrorAssignee: Jason Dillaman <jdillama>
Status: CLOSED ERRATA QA Contact: Parikshith <pbyregow>
Severity: medium Docs Contact: Bara Ancincova <bancinco>
Priority: medium    
Version: 3.0CC: bniver, ceph-eng-bugs, ceph-qe-bugs, jdillama, kdreyer
Target Milestone: rc   
Target Release: 3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-12.1.4-1.el7cp Ubuntu: ceph_12.1.4-2redhat1xenial Doc Type: Bug Fix
Doc Text:
.Restarting `rbd-mirror` is no longer required after a non-orderly shutdown In RBD mirroring configuration, the local non-primary images could not be force promoted after a non-orderly shutdown of the remote cluster. Consequently, if this happened, and the `rbd-mirror` daemon was not restarted on the local cluster, it was not possible to promote the image because the `rbd-mirror` did not release the exclusive lock. This bug has been fixed, and restarting `rbd-mirror` is no longer required in this case.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-05 23:39:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1494421    

Description Harish NV Rao 2017-08-09 07:09:57 UTC
Description of problem:

Unable to write data on the promoted image from secondary rbd host 

creating this bz in 3.0 as per https://bugzilla.redhat.com/show_bug.cgi?id=1365648#c47


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1) Configured mirroring for a newly created image.
2) Performed some I/O's and Turned off all primary cluster machines abruptly.
3) Performed forceful promotion of images in remote cluster using argument '--force'.
4) Tried to perform I/Os on images from remote clusters. Did not work.
5) Tried the worked around -> Restarting the mirroring service - It worked out as expected.

Actual results:
Unable to perform I/Os on images from remote clusters.

Expected results:
Able to perform I/Os on images from remote clusters.

Additional info:
Workaround: Restarting the mirroring service

Comment 8 errata-xmlrpc 2017-12-05 23:39:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387