Bug 1479739

Summary: Wrong action when clicking on SMB server
Product: Red Hat Enterprise Linux 7 Reporter: Marek Kašík <mkasik>
Component: control-centerAssignee: Felipe Borges <feborges>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.4CC: tpelka
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: control-center-3.26.1-3.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-10 12:57:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1479818    

Description Marek Kašík 2017-08-09 10:03:16 UTC
Description of problem:
When I double-click on a SMB server in the new printer dialog I get the "Failed to add new printer." dialog instead of the authentication one.


Version-Release number of selected component (if applicable):
control-center-3.22.2-5


How reproducible:
Always


Steps to Reproduce:
1. Have a SMB server with printers which needs authentication when accessing it
2. Open new printer dialog
3. Double click on the item representing the server


Actual results:
The panel tries to add new printer treating the server as URL of the printer and it fails


Expected results:
Authentication dialog is shown to user so he can provide auth info to see the list of printers on the SMB server


Additional info:
https://git.gnome.org/browse/gnome-control-center/commit/?id=fc073f218522495f6f34374b0b992ebdd4e74583

Comment 5 errata-xmlrpc 2018-04-10 12:57:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770