Bug 1479739 - Wrong action when clicking on SMB server
Wrong action when clicking on SMB server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Felipe Borges
Desktop QE
:
Depends On:
Blocks: 1479818
  Show dependency treegraph
 
Reported: 2017-08-09 06:03 EDT by Marek Kašík
Modified: 2018-05-17 10:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: control-center-3.26.1-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 08:57:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 778277 None None None 2017-08-09 06:03 EDT
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 08:59 EDT

  None (edit)
Description Marek Kašík 2017-08-09 06:03:16 EDT
Description of problem:
When I double-click on a SMB server in the new printer dialog I get the "Failed to add new printer." dialog instead of the authentication one.


Version-Release number of selected component (if applicable):
control-center-3.22.2-5


How reproducible:
Always


Steps to Reproduce:
1. Have a SMB server with printers which needs authentication when accessing it
2. Open new printer dialog
3. Double click on the item representing the server


Actual results:
The panel tries to add new printer treating the server as URL of the printer and it fails


Expected results:
Authentication dialog is shown to user so he can provide auth info to see the list of printers on the SMB server


Additional info:
https://git.gnome.org/browse/gnome-control-center/commit/?id=fc073f218522495f6f34374b0b992ebdd4e74583
Comment 5 errata-xmlrpc 2018-04-10 08:57:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.