Bug 1480410

Summary: [RFE] Kill switch for openstack overcloud deploy
Product: Red Hat OpenStack Reporter: Dan Macpherson <dmacpher>
Component: openstack-heatAssignee: Rabi Mishra <ramishra>
Status: CLOSED ERRATA QA Contact: Ronnie Rasouli <rrasouli>
Severity: medium Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: achernet, akaris, apannu, aschultz, dmacpher, jcoufal, jjoyce, jschluet, jslagle, mburns, rhel-osp-director-maint, sbaker, shardy, smalleni, srevivo, therve, uemit.seren, zbitter
Target Milestone: Upstream M2Keywords: FutureFeature, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-heat-10.0.0-0.20180123134729.85a3e98.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1461563 Environment:
Last Closed: 2018-06-27 13:33:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1461563    
Bug Blocks:    

Comment 1 Red Hat Bugzilla Rules Engine 2017-08-11 01:04:04 UTC
This bugzilla has been removed from the release since it has not been Triaged, and needs to be reviewed for targeting another release.

Comment 2 Red Hat Bugzilla Rules Engine 2017-08-11 01:04:21 UTC
This bugzilla has been removed from the release since it has not been Triaged, and needs to be reviewed for targeting another release.

Comment 4 Thomas Hervé 2017-09-07 11:53:09 UTC
We actually work a on upstream feature to make that it easier.

Comment 5 Thomas Hervé 2017-09-28 14:18:12 UTC
*** Bug 1442161 has been marked as a duplicate of this bug. ***

Comment 14 Ronnie Rasouli 2018-03-15 16:13:33 UTC
Tested with upstream plugin on RHOS13

Comment 16 errata-xmlrpc 2018-06-27 13:33:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086

Comment 17 Uemit Seren 2020-10-14 21:12:25 UTC
When I try to run stack cancel in OSP13 I get:

[[dev]stack@uc ~]$ undercloud stack cancel --no-rollback overcloud
ERROR: You are not authorized to use actions:action.

Any pointers ?

Comment 18 Zane Bitter 2020-10-15 13:29:31 UTC
(In reply to Uemit Seren from comment #17)
> When I try to run stack cancel in OSP13 I get:
> 
> [[dev]stack@uc ~]$ undercloud stack cancel --no-rollback overcloud
> ERROR: You are not authorized to use actions:action.
> 
> Any pointers ?

It was disabled in policy.json as a side-effect of sharing the same policy rule as other actions which are unsafe on the undercloud.

There is a patch in Ussuri to allow finer-grained control of the actions policy: https://review.opendev.org/691181