Bug 1442161 - [RFE]: Give user a way to cancel stack update through a heat command
Summary: [RFE]: Give user a way to cancel stack update through a heat command
Keywords:
Status: CLOSED DUPLICATE of bug 1480410
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 13.0 (Queens)
Assignee: Rabi Mishra
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-13 17:02 UTC by Sai Sindhur Malleni
Modified: 2017-09-28 14:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-28 14:18:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1709041 None None None 2017-08-07 12:19:10 UTC
OpenStack gerrit 491467 'None' MERGED Add REST api support for cancel without rollback 2020-06-26 16:06:36 UTC

Description Sai Sindhur Malleni 2017-04-13 17:02:33 UTC
Description of problem:
Currently, from a TripleO standpoint if the stack create is stuck for a long time at a particular step and the user knows the deployment is going to fail, the only way to cancel the update is to restart heat engine or wait until update is failed after the 240 minute timeout. heat-cancel-update puts things in a really bad state ROLLBACK_FAILED. It would be good to have a cli command to instruct heat to just stop the update.



Version-Release number of selected component (if applicable):

RHOP 10
How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Zane Bitter 2017-04-18 15:44:05 UTC
This has been discussed upstream, at least for convergence, but nobody got around to implementing it yet:

http://lists.openstack.org/pipermail/openstack-dev/2016-August/102016.html

Comment 2 Anandeep Pannu 2017-05-02 18:35:50 UTC
Probably not going to be feasible until  convergence architecture is enabled in the TripleO undercloud.  Looks like an Queens/OSP 13 feature horizon.

Comment 3 Zane Bitter 2017-07-28 22:41:06 UTC
As far as I know, for this to work with convergence we just need to add a --no-rollback option and add it to the ReST API. Internally, the engine's implementation already allows cancelling a stack without rolling it back (this happens e.g. when a sibling resource in the parent stack fails).

SO provided we can enable convergence in TripleO for Queens (the hard part), this should be relatively easy to implement.

Comment 4 Thomas Hervé 2017-09-28 14:18:12 UTC

*** This bug has been marked as a duplicate of bug 1480410 ***


Note You need to log in before you can comment on or make changes to this bug.