Bug 1483592

Summary: broken navigation when user clicks quad icon on Provider Edit Tags page and then Tags Assignment in breadcrumb
Product: Red Hat CloudForms Management Engine Reporter: Ievgen Zapolskyi <izapolsk>
Component: UI - OPSAssignee: lgalis
Status: CLOSED WONTFIX QA Contact: Dave Johnson <dajohnso>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.8.0CC: hkataria, jhardy, mpovolny, obarenbo
Target Milestone: GA   
Target Release: cfme-future   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ui:tag
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-11 16:54:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: Bug
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core Target Upstream Version:

Description Ievgen Zapolskyi 2017-08-21 13:06:41 UTC
Description of problem:
When user clicks some provider quadicon on Edit Tags page, CFME opens Dashboard view for that provider. BreadCrum on Dashboard view has a Tag Assignment location.
Empty page with broken url (see screenshot) gets displayed if user clicks Tag Assignment in breadcrumb.
Such breadcrumb location is absent on Provider Summary View.

I suppose this issue should be applicable for other similar locations as well.
F.e. if user did the same in Manage Policies view, he would have error -

User 'admin' is not authorized to access 'Infrastructure Provider' record id '0'

Version-Release number of selected component (if applicable):
5.8.1.5

How reproducible:
100%

Steps to Reproduce:
1. Add two infrastructure providers to appliance
2. make sure Dashboard view is displayed when user clicks some infra provider
3. check both providers on All Infra Providers page
4. Choose Policy->Edit Tags
5. Click some provider quadicon there
6. Click Tag Assignment location in breadcrumb 

Actual results:
empty page with url "https://tagging_edit/" appears


Expected results:
either no such breadcrumb location or it should work correctly