Bug 1492589

Summary: [RGW:NFS]: Writing a large size file fails on the NFS mount
Product: Red Hat Ceph Storage Reporter: Vidushi Mishra <vimishra>
Component: RGWAssignee: Matt Benjamin (redhat) <mbenjamin>
Status: CLOSED ERRATA QA Contact: Vidushi Mishra <vimishra>
Severity: medium Docs Contact: Bara Ancincova <bancinco>
Priority: high    
Version: 3.0CC: anharris, cbodley, ceph-eng-bugs, flucifre, hnallurv, jbrier, kbader, kdreyer, mbenjamin, owasserm, rperiyas, sweil
Target Milestone: rc   
Target Release: 3.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-12.2.5-35.el7cp Ubuntu: ceph_12.2.5-20redhat1xenial Doc Type: Known Issue
Doc Text:
.The Ceph Object Gateway requires applications to write sequentially The Ceph Object Gateway requires applications to write sequentially from offset 0 to the end of a file. Attempting to write out of order causes the upload operation to fail. To work around this issue, use utilities like `cp`, `cat`, or `rsync` when copying files into NFS space. Always mount with the `sync` option.
Story Points: ---
Clone Of:
: 1647139 (view as bug list) Environment:
Last Closed: 2018-09-26 18:16:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1494421, 1584264    

Description Vidushi Mishra 2017-09-18 09:19:53 UTC
Description of problem:
Cannot write a large size file on the NFS mount. Tried writing 500Mb but it fails with IO error.
[root@host mnt2]# dd if=/dev/urandom of=test2/file1  bs=10M count=50
dd: closing output file ‘test2/file1’: Input/output error
[root@host mnt2]# 
Considering S3 has a limit of 5GB in a single PUT operation, what is the maximum file size we can directly write in a directory in the NFS mount? 

Version-Release number of selected component (if applicable):
ceph version 12.2.0-2.el7cp
nfs-ganesha-rgw-2.5.2-2.el7cp.x86_64
nfs-ganesha-2.5.2-2.el7cp.x86_64

How reproducible:
3/3

Steps to Reproduce:
1. Configure NFS server on an RGW  and configure NFS client and mount share with NFSv3.
2. Create a file and write 500Mb of data
3. Operation fails with IO error

Actual results:


Expected results:

Comment 26 errata-xmlrpc 2018-09-26 18:16:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819