Bug 1584264 - [Tracker] RHCS 3.1 Release Notes
Summary: [Tracker] RHCS 3.1 Release Notes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.1
Assignee: ceph-docs@redhat.com
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On: 1595288 1609713 1763219 1430536 1466956 1472868 1482739 1486830 1492342 1492589 1494256 1494987 1498303 1501380 1502021 1504291 1506102 1508451 1508460 1517912 1517915 1536795 1537035 1537390 1537445 1537505 1537737 1539663 1547999 1548563 1548564 1554281 1560101 1561758 1562388 1562389 1564520 1566514 1569192 1569413 1571353 1572722 1575829 1578140 1578142 1580300 1582411 1585029 1585031 1585239 1585307 1585750 1588093 1589545 1590746 1591074 1591822 1591873 1591877 1592497 1595379 1595833 1596061 1596401 1597425 1597516 1597930 1599005 1599859 1599873 1600943 1601580 1602785 1602882 1605241 1608060 1609007 1609427 1610876 1613155 1613626 1613826 1614498 1614780 1615872 1616066 1618678 1619090 1619098 1621255 1621901 1622697 1623601 1623650 1624417 1624527 1624646 1626239 1627725 1628055 1630430 1630870 1632157 1633563 1634786 1634964 1635303 1646882 1670781 1673654 1728710 1744766
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-30 15:05 UTC by Anjana Suparna Sriram
Modified: 2019-10-18 14:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 13:09:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Anjana Suparna Sriram 2018-05-30 15:05:41 UTC
This tracker bug is not a tracker just for known issues but for every change that should appear in the Release Notes - major updates, technical previews, deprecated functions, and so on.

If there is a change that does not have a separate bug (for example it is a change introduced in a rebase), add that rebase bug as a blocker and specify the nature of the change in the doc text field of that bug.

**How to let us know that a bug should be documented in the Release Notes**

1) Add the BZ number of the bug that needs to be documented to the "Depends On" field in the Release Notes tracker bug. Alternatively, add the tracker bug BZ number to the "Blocks" field in the bug that needs to be documented.

2) In the bug that needs to be documented, set the doctype to one of the following:

* bug fix - for notable bug fixes that have a significant impact on customers

* enhancement - for new features and major enhancements, RFE bugs

* technology preview - for new features shipped as tech previews

* known issues - for the known issues found in this release

3) In the bug that needs to be documented, fill in the Doc Text field with the initial information. Use the template that is in the field.

----

**Candidates for inclusion**

* Bugs with a customer case attached

* Major new features and enhancements

* Bugs with significant impact on users

* Urgent or high priority bugs

* Fixed known issues

----

**How a good initial description looks like**

* Use the cause-consequence-fix-result (CCFR) format for bug fixes:

  Cause – what user action or circumstances trigger this bug 
    
  Consequence – what the user experiences when the bug occurs 
   
  Fix – what has been changed to fix the bug (overly technical details are not necessary)
    
  Result – what happens now with the fix applied

* Use the feature-reason-result (FFR) format for major updates:

    Feature – describes the enhancement from the user's point of view
    
    Reason – why was the enhancement implemented
    
    Result – what is the current user experience (may also be compared to the previous user experience)

----

**I want to document a change that does not have a bug - how to do it?**

Add a comment here, we will add that description manually.

Comment 3 John Brier 2018-08-21 15:55:29 UTC
@Madhavi This bug you added was changed to target release 3.2 so I don't think it is relevant to the 3.1 release notes:

Bug 1613826 - [iscsi-ansible] Add support for iscsi target and tcmu device controls

Do you mind if I remove it from this release notes tracker? You can remove it also if you want.

Comment 6 sagrawal 2018-09-06 10:37:20 UTC
The issue reported in
Bug 1595288 - [cephmetrics] iSCSI Overview grafana page does not display graphs/values is still present.

This should be included in Release Notes.


Note You need to log in before you can comment on or make changes to this bug.