Bug 1503521 (ovndns)

Summary: [Neutron][OVN][RFE] internal DNS support
Product: Red Hat OpenStack Reporter: Miguel Angel Ajo <majopela>
Component: python-networking-ovnAssignee: Numan Siddique <nusiddiq>
Status: CLOSED ERRATA QA Contact: Miguel Angel Ajo <majopela>
Severity: medium Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: apevec, dalvarez, ekuris, jlibosva, lhh, majopela, nusiddiq, nyechiel, tfreger
Target Milestone: Upstream M2Keywords: FutureFeature, TechPreview, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-networking-ovn-4.0.1-0.20180420150809.c7c16d4.el7ost Doc Type: Release Note
Doc Text:
This version introduces support for internal DNS resolution in networking-ovn. Although there are two know limitations, one is bz#1581332 which prevents proper resolution of internal fqdn requests via internal dns. Please note that the extension is not configured by default by tripleo on the GA release. See bz#1577592 for a workaround.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:37:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1577592, 1581332, 1582512    
Bug Blocks: 1498491    

Description Miguel Angel Ajo 2017-10-18 11:20:07 UTC
Description of problem:

Neutron provides the capability to assign DNS names to ports through the DNS extension. Historically that was automatic, and now nova uses the DNS extension in neutron when found to fill in the dns details.

While Core OVN is capable of responding to DNS queries and forwarding them as necessary networking-ovn mechanism driver doesn't still implement that. It'd be highly desirable for parity reasons to support that feature.


https://github.com/openvswitch/ovs/blob/adabd65ddd8217cf1a27f654136ff74d4fd544bf/ovn/ovn-nb.ovsschema#L48

https://github.com/openvswitch/ovs/blob/adabd65ddd8217cf1a27f654136ff74d4fd544bf/ovn/ovn-nb.ovsschema#L288

Expected outcome:

 Support of the dns neutron extension, and enablement of the dns related tests.

Comment 1 Miguel Angel Ajo 2017-10-18 11:28:54 UTC
Some examples of how to configure it at OVN level: https://github.com/openvswitch/ovs/blob/adabd65ddd8217cf1a27f654136ff74d4fd544bf/tests/ovn.at#L6598

As per @numans explanation, this feature works by capturing any DNS request, and responding locally on OVN controller if we have an answer, otherwise the packet is released back to the openflow pipeline and will reach the normal DNS server if that was configured via DHCP.

One thing that we could have here missing compared to neutron is the ability to do inverse resolution, but that could be easily added to core-ovn later.

Comment 4 Daniel Alvarez Sanchez 2017-12-20 17:49:52 UTC
https://review.openstack.org/#/c/522215/ is merged

Comment 15 Miguel Angel Ajo 2018-06-10 22:35:39 UTC
It was verified, but two bugs were opened:

1581332 and 1577592

Comment 17 errata-xmlrpc 2018-06-27 13:37:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086