Bug 1581332 - Internal DNS resolution does not work for fqdn
Summary: Internal DNS resolution does not work for fqdn
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z2
: 13.0 (Queens)
Assignee: Miguel Angel Ajo
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks: ovndns
TreeView+ depends on / blocked
 
Reported: 2018-05-22 14:20 UTC by Miguel Angel Ajo
Modified: 2019-09-09 13:07 UTC (History)
7 users (show)

Fixed In Version: python-networking-ovn-4.0.1-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 16:20:28 UTC
Target Upstream Version:
majopela: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1757074 None None None 2018-05-22 14:20:34 UTC
OpenStack gerrit 556828 None stable/queens: MERGED networking-ovn: Strip the trailing '.' from the fqdn dns record stored in OVN NB DB (I8cdc48065acdac9dcc5955c223824714ec... 2018-07-05 10:25:02 UTC
Red Hat Product Errata RHBA-2018:2596 None None None 2018-08-29 16:20:51 UTC

Description Miguel Angel Ajo 2018-05-22 14:20:34 UTC
Description of problem:

when dns records are added for a port in OVN NB DB, the extra "." is also added.
Eg. "vm1.ovn.test."="10.0.0.4" is added.

It should be "vm1.ovn.test"="10.0.0.4"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Miguel Angel Ajo 2018-05-22 14:23:26 UTC
The fix for this was merged 8 weeks ago, and got backported to stable/queens 4 weeks ago, but it didn't land the import.

We need to make sure it will land the zstream release, and that we provide a Release Note

Comment 9 Eran Kuris 2018-08-09 08:06:34 UTC
fix verified: 
python-networking-ovn-4.0.2-2.el7ost.noarch

OSP-13 2018-08-07.5

Comment 10 Joanne O'Flynn 2018-08-13 14:08:03 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 12 errata-xmlrpc 2018-08-29 16:20:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2596


Note You need to log in before you can comment on or make changes to this bug.