Bug 1516755

Summary: Cannot install Calibre due to incompatible qt version
Product: [Fedora] Fedora Reporter: Daniel Boiko <5n00p4eg>
Component: calibreAssignee: Kevin Fenzi <kevin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: chkr, helio, jason.bergmann, kevin, nathan, nushio, ral, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: calibre-3.12.0-1.fc27 calibre-3.12.0-1.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-28 23:55:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Boiko 2017-11-23 11:09:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Fedora release 26 (Twenty Six)



Steps to Reproduce:
1. sudo dnf install calibre


Actual results:
  - package calibre-3.11.1-1.fc26.x86_64 requires qt5-qtbase(x86-64) = 5.7.1, but none of the providers can be installed
  - package calibre-3.0.0-2.fc26.x86_64 requires qt5-qtbase(x86-64) = 5.7.1, but none of the providers can be installed
  - problem with installed package qt5-doctools-5.9.2-1.fc26.x86_64
  - package qt5-doctools-5.9.2-1.fc26.x86_64 requires libQt5Core.so.5(Qt_5.9)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtbase-5.7.1-15.fc26.x86_64 and qt5-qtbase-5.9.2-4.fc26.x86_64


Expected results:
Installed calibre.

Additional info:

Last metadata expiration check: 0:08:07 ago on Thu Nov 23 13:00:30 2017.
Available Packages
Name         : calibre
Version      : 3.11.1
Release      : 1.fc26
Arch         : x86_64
Size         : 29 M
Source       : calibre-3.11.1-1.fc26.src.rpm
Repo         : updates
Summary      : E-book converter and library manager
URL          : http://calibre-ebook.com/
License      : GPLv3

Comment 1 Kevin Fenzi 2017-11-23 18:53:36 UTC
Yeah, sorry about this... will push a fixed update here soon...

Comment 2 Fedora Update System 2017-11-23 20:57:14 UTC
calibre-3.12.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5fcc1f8323

Comment 3 Fedora Update System 2017-11-23 20:57:22 UTC
calibre-3.12.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a72a8320d1

Comment 4 Fedora Update System 2017-11-25 00:37:08 UTC
calibre-3.12.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5fcc1f8323

Comment 5 Fedora Update System 2017-11-25 01:35:36 UTC
calibre-3.12.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a72a8320d1

Comment 6 Daniel Boiko 2017-11-25 08:19:52 UTC
Thanks, I will check on Monday )

Comment 7 Fedora Update System 2017-11-28 23:55:20 UTC
calibre-3.12.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Jason Bergmann 2017-11-29 01:45:40 UTC
Will this update also get pushed to fc26?

Comment 9 Kevin Fenzi 2017-11-29 05:25:12 UTC
(In reply to Jason Bergmann from comment #8)
> Will this update also get pushed to fc26?

Yes. It just needs one more karma to go to stable updates: 

https://bodhi.fedoraproject.org/updates/FEDORA-2017-a72a8320d1

Comment 10 Nathan 2017-11-29 14:13:31 UTC
Just added 1 karma.

Comment 11 Kevin Fenzi 2017-11-29 17:34:11 UTC
Alas, you were not logged in and karma isn't counted from non logged in accounts. ;(

Comment 12 Nathan 2017-11-29 18:03:59 UTC
That should be taken care of now - thanks for the heads up.

Comment 13 Jason Bergmann 2017-11-30 00:05:02 UTC
Just added 1 karma.  Calibre 3.12.0-1.fc26 is still in updates-testing for fc26.

Comment 14 Zbigniew Jędrzejewski-Szmek 2017-12-02 10:33:53 UTC
*** Bug 1520000 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2017-12-02 21:23:07 UTC
calibre-3.12.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.