Bug 1543396

Summary: A-MQ Components not visible in Java Console when using IE11 browser
Product: OpenShift Container Platform Reporter: Alexandre Kieling <abrianik>
Component: Management ConsoleAssignee: Alexandre Kieling <abrianik>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.4.1CC: aos-bugs, jforrest, jokerman, juzhao, mmccomas, spadgett, yapei
Target Milestone: ---   
Target Release: 3.4.z   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: use of javascript Array method not supported by IE11 (Array.find, Array.findIndex) Consequence: Error that prevents some A-MQ pages to show content when the user clicks on a tree node Fix: Replace the unsupported Array methods with the Lodash library Result: A-MQ pages show their content as expected
Story Points: ---
Clone Of: 1518407
: 1543402 (view as bug list) Environment:
Last Closed: 2018-04-18 07:00:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1518407, 1543435, 1543467, 1543525, 1543532    
Bug Blocks: 1519573, 1543402    

Comment 1 Alexandre Kieling 2018-02-12 14:05:41 UTC
Pull request:
https://github.com/openshift/origin-web-console/pull/2786

Comment 2 Alexandre Kieling 2018-03-09 18:25:33 UTC
I think this issue can be tested.

Comment 4 Junqi Zhao 2018-04-03 02:41:29 UTC
The right pane shows details about the selected tree node in IE 11 now.

IE Version: 11.309.16299.0
# openshift version
openshift v3.4.1.44.52
kubernetes v1.4.0+776c994
etcd 3.1.0-rc.0

openshift-jvm version:  1.2.6

Comment 7 errata-xmlrpc 2018-04-18 07:00:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1134