Bug 1519573 - A-MQ Components not visible in Java Console when using IE11 browser (master)
Summary: A-MQ Components not visible in Java Console when using IE11 browser (master)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 3.x
Assignee: Alexandre Kieling
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1518407 1543396 1543402 1543435 1543467 1543525 1543532
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 22:51 UTC by Alexandre Kieling
Modified: 2018-03-20 21:07 UTC (History)
7 users (show)

Fixed In Version: 1.3.0-alpha
Doc Type: Bug Fix
Doc Text:
Cause: use of javascript Array method not supported by IE11 (Array.find, Array.findIndex) Consequence: Error that prevents some A-MQ pages to show content when the user clicks on a tree node Fix: Replace the unsupported Array methods with the Lodash library Result: A-MQ pages show their content as expected
Clone Of: 1518407
Environment:
Last Closed: 2018-03-20 21:07:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
the right pane could show details about the selected tree node in IE 11 (76.70 KB, image/png)
2018-01-23 09:43 UTC, Junqi Zhao
no flags Details

Description Alexandre Kieling 2017-11-30 22:51:34 UTC
Description of problem:
A-MQ Components not visible in Java Console when using IE11 browser

How reproducible:
Always

Steps to Reproduce:
1. Deploy JBoss A-MQ 6.3 for OpenShift
2. Edit deployment configuration and set name "jolokia" to 8778 port
3. Open the Java console
4. Click on the ActiveMQ menu item
5. Click on tree nodes in the left pane

Actual results:
No content is shown in the right pane

Expected results:
The right pane should show details about the selected tree node

Additional info:
Check the browser console for errors

Comment 2 Jessica Forrester 2018-01-22 13:56:18 UTC
moving to ON_QA since this is in origin component

Comment 3 Junqi Zhao 2018-01-23 09:40:33 UTC
@Alexandre,
How do you create application, so you can open Java console?

I only used JBoss A-MQ 6.3 image, and created broker-amq pod, and opened Java console in IE 11, the right pane could show details about the selected tree node.

See the attached picture

Comment 4 Junqi Zhao 2018-01-23 09:43:21 UTC
Created attachment 1384783 [details]
the right pane could show details about the selected tree node in IE 11

Comment 5 Alexandre Kieling 2018-01-23 09:55:27 UTC
The Java console can be opened for any application that exposes a port with number 8778 and name 'jolokia'. Some images expose port 8778 but don't name it 'jolokia'. 

JBoss A-MQ 6.3 is a good image to test the ActiveMQ features. JBoss Fuse for OpenShift can be used to test other parts of the Java console. 

Alternatively, you can create and deploy a FIS application (https://access.redhat.com/documentation/en-us/red_hat_jboss_fuse/6.3/html-single/fuse_integration_services_2.0_for_openshift/index).

PS: The screenshot shows the app working as expected. Before the bug fix, you couldn't see anything on the right-hand panel when selecting different tree nodes.

Comment 6 Junqi Zhao 2018-01-24 02:25:59 UTC
Set it to VERIFIED as per Comment 3 and Comment 4

Comment 7 Junqi Zhao 2018-01-24 02:26:23 UTC
IE version: 11.850.15063.0


Note You need to log in before you can comment on or make changes to this bug.