Bug 1549995

Summary: eclipse on aarch64
Product: [Fedora] Fedora Reporter: elatllat
Component: eclipseAssignee: Mat Booth <mat.booth>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 27CC: akurtako, ebaron, jerboaa, jeremy.linton, krzysztof.daniel, lef, mat.booth, rgrunber
Target Milestone: ---   
Target Release: ---   
Hardware: aarch64   
OS: Linux   
Whiteboard:
Fixed In Version: eclipse-4.7.3a-5.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-26 20:42:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    

Description elatllat 2018-02-28 09:12:06 UTC
Description of problem:
  eclipse on aarch64 fails to start

Version-Release number of selected component (if applicable):
  dnf info eclipse-jdt
  Last metadata expiration check: 0:30:19 ago on Wed 28 Feb 2018 03:28:14 AM EST.
  Installed Packages
  Name         : eclipse-jdt
  Epoch        : 1
  Version      : 4.7.2
  Release      : 1.fc27
  Arch         : noarch
  Size         : 33 M
  Source       : eclipse-4.7.2-1.fc27.src.rpm
  Repo         : @System
  From repo    : updates
  Summary      : Eclipse Java Development Tools
  URL          : http://www.eclipse.org/
  License      : EPL
  Description  : Eclipse Java Development Tools.  This package is required to use 
  Eclipse for
               : developing software written in the Java programming language.


How reproducible:
  every time

Steps to Reproduce:
  1. use aarch64
  2. dnf install eclipse-jdt
  2. eclipse

Actual results:
  "The Eclipse executable launcher was unable to locate its companion shared library"

Expected results:
  Eclipse runs

Additional info:
  likely the same issue with any eclipse flavor (eclipse-cdt, etc)
  https://bugs.eclipse.org/bugs/show_bug.cgi?id=482387
  tail /var/log/* 2>/dev/null | grep -i eclipse

Comment 1 Mat Booth 2018-02-28 10:24:47 UTC
Interesting, thanks for the report. You are likely the first person to really try using Eclipse on aarch64 :-o

Comment 2 elatllat 2018-02-28 11:10:35 UTC
Now that it's easy to get aarch64 with 4GB+ RAM I expect the architecture will be getting more popular outside the phone market soon.

I'm using the RK3399 SOC for which there are ~20 consumer products including a Samsung laptop, and an Odroid SBC.

Comment 3 Mat Booth 2018-05-18 16:29:19 UTC
*** Bug 1579902 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Linton 2018-05-18 16:47:43 UTC
I think this may have been working in the F26 timeframe, I had it installed, and basically ran through the menus on my "desktop" machine after upgrading it to f28 checking if everything started, and it was one of the things that failed.

So its still broken in f28.

Comment 5 elatllat 2018-05-18 17:36:55 UTC
If F26 was using code from between 2015-11-19 and 2017-01-12 (YYYY-MM-DD) it might have worked because that is when eclipse built for aarch64 and as far as I know all distributions with eclipse builds after version 3.x just package upstream binaries; 

https://git.eclipse.org/r/plugins/gitiles/platform/eclipse.platform.swt/+/45c115df7ed7bb612de6b4f47e68bfae761c5d0a%5E%21/#F0


https://git.eclipse.org/r/plugins/gitiles/platform/eclipse.platform.swt/+/765d670fdeea29a4eac7d4137bbdb26169047874%5E%21/#F0

Comment 6 Mat Booth 2018-05-18 17:43:03 UTC
We build all our binaries from source in Fedora. I have added what I hope is the fix to get the arm binaries working to the rawhide branch, but rawhide Eclipse is currently broken for unrelated reasons.

I will backport my fix to F28/F27 and I would appreciate your testing since I have no real access to arm hardware right now :-) -- I will report back here once a testable build completes

Comment 7 Fedora Update System 2018-05-22 09:20:54 UTC
eclipse-4.7.3a-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7f3781204a

Comment 8 Mat Booth 2018-05-22 09:22:31 UTC
(In reply to Fedora Update System from comment #7)
> eclipse-4.7.3a-5.fc28 has been submitted as an update to Fedora 28.
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-7f3781204a

Can you try with this build on F28?

Feedback would be greatly appreciated!

Comment 9 Jeremy Linton 2018-05-22 15:54:00 UTC
Looks like its working now, that I fixed a nfs lock problem.

Thanks,

Comment 10 Mat Booth 2018-05-22 16:26:44 UTC
Thanks for testing :-)

Comment 11 Fedora Update System 2018-05-22 19:38:53 UTC
eclipse-4.7.3a-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7f3781204a

Comment 12 Fedora Update System 2018-05-26 20:42:20 UTC
eclipse-4.7.3a-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.