Bug 1563253

Summary: [OSP13] neutron_api docker container in unhealthy state
Product: Red Hat OpenStack Reporter: Artem Hrechanychenko <ahrechan>
Component: openstack-tripleo-commonAssignee: Bernard Cafarelli <bcafarel>
Status: CLOSED ERRATA QA Contact: Toni Freger <tfreger>
Severity: medium Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: amuller, bcafarel, chrisw, dschoenb, dsorrent, ekuris, jschluet, mburns, nyechiel, slinaber, srevivo
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-tripleo-common-8.6.1-5.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:50:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Artem Hrechanychenko 2018-04-03 12:58:13 UTC
Description of problem:

[heat-admin@controller-0 ~]$ sudo docker ps |grep "unhealthy"
b13895cb95f4        192.168.24.1:8787/rhosp13/openstack-neutron-server:2018-03-29.1              "kolla_start"            About an hour ago   Up About an hour (unhealthy)  neutron_api                    


Version-Release number of selected component (if applicable):
openstack-neutron-server:2018-03-29.1

How reproducible:
always

Steps to Reproduce:
1.Deploy osp13 with containerized neutron

Actual results:
neutron_api health check == unhealthy

Expected results:
neutron_api health check == healthy

Additional info:

Comment 2 Bernard Cafarelli 2018-04-04 08:55:50 UTC
Running health-check command in container:

()[neutron@controller-0 /]$ /openstack/healthcheck 
awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)
awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)
grep: /etc/httpd/conf.d/10-neutron_wsgi.conf: No such file or directory

neutron wsgi does not use apache

Comment 3 Bernard Cafarelli 2018-04-26 12:52:09 UTC
*** Bug 1572184 has been marked as a duplicate of this bug. ***

Comment 10 Jon Schlueter 2018-05-17 19:26:00 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1555347 appears to overlap with this one but not certain if they are duplicates or not.

Comment 11 Bernard Cafarelli 2018-05-18 09:06:18 UTC
I would say same topic, but different issues:
health check scripts existed before, but were not installed properly (this is the main fix in https://bugzilla.redhat.com/show_bug.cgi?id=1555347). For neutron_api it was buggy though, so it was fixed here.

Comment 12 Eran Kuris 2018-06-25 07:28:56 UTC
Verified : 
osp13 - 2018-06-20.1
 openstack-tripleo-common-8.6.1-20.el7ost.noarch.rpm

Comment 14 errata-xmlrpc 2018-06-27 13:50:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086