Bug 1572184 - Post upgrade, the neutron_api is unhealthy
Summary: Post upgrade, the neutron_api is unhealthy
Keywords:
Status: CLOSED DUPLICATE of bug 1563253
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 11:06 UTC by Darin Sorrentino
Modified: 2018-04-26 12:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 12:52:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Darin Sorrentino 2018-04-26 11:06:29 UTC
Description of problem:

[root@overcloud-controller-0 neutron]# docker ps | grep neutron_api
39d0325762a7        docker-registry.engineering.redhat.com/rhosp13/openstack-neutron-server:2018-04-24.1              "kolla_start"            20 hours ago        Up 5 minutes (unhealthy)                       neutron_api

[root@overcloud-controller-0 neutron]# docker inspect --format='{{json .State.Health}}' neutron_api
{"Status":"unhealthy","FailingStreak":10,"Log":[{"Start":"2018-04-26T07:03:07.106923225-04:00","End":"2018-04-26T07:03:07.237302172-04:00","ExitCode":1,"Output":"awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\nawk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\ngrep: /etc/httpd/conf.d/10-neutron_wsgi.conf: No such file or directory\n  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current\n                                 Dload  Upload   Total   Spent    Left  Speed\n\r  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: ; Unknown error\n\n000 :0 0.000 seconds\n"},{"Start":"2018-04-26T07:03:37.240063614-04:00","End":"2018-04-26T07:03:37.319402727-04:00","ExitCode":1,"Output":"awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\nawk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\ngrep: /etc/httpd/conf.d/10-neutron_wsgi.conf: No such file or directory\n  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current\n                                 Dload  Upload   Total   Spent    Left  Speed\n\r  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: ; Unknown error\n\n000 :0 0.001 seconds\n"},{"Start":"2018-04-26T07:04:07.326895953-04:00","End":"2018-04-26T07:04:07.44354158-04:00","ExitCode":1,"Output":"awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\nawk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\ngrep: /etc/httpd/conf.d/10-neutron_wsgi.conf: No such file or directory\n  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current\n                                 Dload  Upload   Total   Spent    Left  Speed\n\r  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: ; Unknown error\n\n000 :0 0.001 seconds\n"},{"Start":"2018-04-26T07:04:37.445116444-04:00","End":"2018-04-26T07:04:37.572729334-04:00","ExitCode":1,"Output":"awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\nawk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\ngrep: /etc/httpd/conf.d/10-neutron_wsgi.conf: No such file or directory\n  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current\n                                 Dload  Upload   Total   Spent    Left  Speed\n\r  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0\n000 :0 0.000 seconds\ncurl: (6) Could not resolve host: ; Unknown error\n"},{"Start":"2018-04-26T07:05:07.575085638-04:00","End":"2018-04-26T07:05:07.725399753-04:00","ExitCode":1,"Output":"awk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\nawk: fatal: cannot open file `/etc/httpd/conf.d/10-neutron_wsgi.conf' for reading (No such file or directory)\ngrep: /etc/httpd/conf.d/10-neutron_wsgi.conf: No such file or directory\n  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current\n                                 Dload  Upload   Total   Spent    Left  Speed\n\r  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: ; Unknown error\n\n000 :0 0.003 seconds\n"}]}

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Bernard Cafarelli 2018-04-26 12:52:09 UTC
This is not only on upgrade, clean installs have the problem too. Merging with main issue

*** This bug has been marked as a duplicate of bug 1563253 ***


Note You need to log in before you can comment on or make changes to this bug.