Bug 1566007

Summary: [RFE] Deploy OCP clusters on bare metal nodes by OpenStack tenants in the Overcloud
Product: OpenShift Container Platform Reporter: Ramon Acedo <racedoro>
Component: RFEAssignee: Tzu-Mainn Chen <tzumainn>
Status: CLOSED WONTFIX QA Contact: weiwei jiang <wjiang>
Severity: high Docs Contact:
Priority: high    
Version: 3.10.0CC: aos-bugs, jeder, jokerman, ltomasbo, mmccomas, tsedovic, tzumainn, wsun
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-12 11:55:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1566010    

Description Ramon Acedo 2018-04-11 10:28:39 UTC
As a tenant, I want to deploy OpenShift on OpenStack using bare metal nodes for the OpenShift Cluster. 

openshift-ansible Playbooks that allow deploying OpenShift on OpenStack virtual instances should be able to do the same on physical instances using Ironic.

Comment 1 Tzu-Mainn Chen 2018-05-24 15:24:17 UTC
*** Bug 1503734 has been marked as a duplicate of this bug. ***

Comment 3 Kirsten Newcomer 2019-06-12 11:55:50 UTC
With the introduction of OpenShift 4, Red Hat has delivered or roadmapped a substantial number of features based on feedback by our customers.  Many of the enhancements encompass specific RFEs which have been requested, or deliver a comparable solution to a customer problem, rendering an RFE redundant.

This bz (RFE) has been identified as a feature request not yet planned or scheduled for an OpenShift release and is being closed. 

If this feature is still an active request that needs to be tracked, Red Hat Support can assist in filing a request in the new JIRA RFE system, as well as provide you with updates as the RFE progress within our planning processes. Please open a new support case: https://access.redhat.com/support/cases/#/case/new 

Opening a New Support Case: https://access.redhat.com/support/cases/#/case/new 

As the new Jira RFE system is not yet public, Red Hat Support can help answer your questions about your RFEs via the same support case system.