Bug 1503734 - [RFE] Deploy OpenShift on OpenStack Bare-metal-to-tenant via Ironic
Summary: [RFE] Deploy OpenShift on OpenStack Bare-metal-to-tenant via Ironic
Keywords:
Status: CLOSED DUPLICATE of bug 1566007
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.8.0
Assignee: Tzu-Mainn Chen
QA Contact: GenadiC
URL:
Whiteboard: DFG:OpenShiftonOpenStack
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-18 15:40 UTC by Tzu-Mainn Chen
Modified: 2018-05-24 15:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 15:24:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tzu-Mainn Chen 2017-10-18 15:40:59 UTC
Description of problem:

As an operator, I want to deploy my OpenShift cluster on baremetal managed by the same infrastructure platform as my virtual machines.

NB: Here we refer to baremetal in the overcloud, this is not to be confused with separate efforts to deploy OpenShift from the undercloud using splitstack.



Expected results:

* As an OpenStack user I am able to provision bare-metal machines in the overcloud with RHEL Atomic with networking access.
* As an OpenStack user I am able to use openshift-ansible against these machines to get a functionally equivalent OpenShift environment to that I get running it against Vms.

Comment 1 Tzu-Mainn Chen 2018-05-24 15:24:17 UTC
This is being replaced by https://bugzilla.redhat.com/show_bug.cgi?id=1566007

*** This bug has been marked as a duplicate of bug 1566007 ***


Note You need to log in before you can comment on or make changes to this bug.