Bug 1566073

Summary: Linker error
Product: [Fedora] Fedora Reporter: Pier Luigi Fiorini <pierluigi.fiorini>
Component: qt5-qtquickcontrols2Assignee: Rex Dieter <rdieter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 28CC: pierluigi.fiorini
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-12 17:42:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pier Luigi Fiorini 2018-04-11 13:12:16 UTC
Description of problem:

I'm building a package on COPR against F28 but it fails, see: https://copr-be.cloud.fedoraproject.org/results/plfiorini/liri-unstable/fedora-28-x86_64/00739805-fluid/build.log.gz
Bulding against Rawhide works.


How reproducible:

Build software that is linked to /usr/lib64/libQt5QuickControls2.so.5.10.1


Actual results:

Linker error.


Expected results:

Builds ok.


Additional info:

COPR: https://copr.fedorainfracloud.org/coprs/plfiorini/liri-unstable/packages/
Package: https://copr.fedorainfracloud.org/coprs/plfiorini/liri-unstable/package/fluid/

Comment 1 Pier Luigi Fiorini 2018-04-12 06:42:58 UTC
The error is:

linking fluid-demo
BUILDSTDERR: ERROR: /usr/bin/g++ -Wl,-m,elf_x86_64,-rpath,/usr/lib64 -L/usr/lib64 -m64 -o /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/fluid-demo /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/iconcategorymodel.cpp.o /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/iconnamemodel.cpp.o /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/main.cpp.o /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/qrc_fluid-demo.cpp.o /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/73489b871e127538/moc_iconcategorymodel.cpp.o /builddir/build/BUILD/fluid-bd026f71f0bfe059d7d5baa917694ef780cbdb9f/build/default/fluid-demo.621c3a4a/73489b871e127538/moc_iconnamemodel.cpp.o /usr/lib64/libQt5Core.so.5.10.1 /usr/lib64/libQt5Gui.so.5.10.1 /usr/lib64/libQt5Network.so.5.10.1 /usr/lib64/libQt5Qml.so.5.10.1 /usr/lib64/libQt5Quick.so.5.10.1 /usr/lib64/libQt5QuickControls2.so.5.10.1
BUILDSTDERR: ERROR: //usr/lib64/libQt5QuickTemplates2.so.5:(*IND*+0x0): multiple definition of `_end'
BUILDSTDERR: //usr/lib64/libQt5QuickTemplates2.so.5:(*IND*+0x0): multiple definition of `__bss_start'
BUILDSTDERR: collect2: error: ld returned 1 exit status
BUILDSTDERR: ERROR: Process failed with exit code 1.
BUILDSTDERR: The following products could not be built for configuration default:
BUILDSTDERR: fluid-demo

Comment 2 Rex Dieter 2018-04-12 17:42:37 UTC
dup of binutils bug #1458003

Comment 3 Rex Dieter 2018-04-12 17:42:55 UTC

*** This bug has been marked as a duplicate of bug 1458003 ***