Bug 1458003 - linker failures with duplicate symbols
Summary: linker failures with duplicate symbols
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 28
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1566073 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-01 18:09 UTC by Rex Dieter
Modified: 2018-05-05 20:33 UTC (History)
5 users (show)

Fixed In Version: binutils-2.28-8.fc27, binutils-2.29.1-21.fc28 binutils-2.29.1-23.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-05 20:33:40 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Sourceware 21074 0 P2 ASSIGNED [2.28 Regression] bfd ld stumbles over duplicated symbols generated by gold 2020-01-22 00:39:53 UTC

Description Rex Dieter 2017-06-01 18:09:58 UTC
I'm experiencing a package build failure with kphotoalbum,

https://koji.fedoraproject.org/koji/taskinfo?taskID=19803065

interestingly, only on selected archs, but all fail with similar:

/usr/lib64/libQt5Network.so.5.9.0:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Network.so.5.9.0:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Network.so.5.9.0:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Widgets.so.5.9.0:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Widgets.so.5.9.0:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Widgets.so.5.9.0:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Gui.so.5.9.0:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Gui.so.5.9.0:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Gui.so.5.9.0:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Core.so.5.9.0:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Core.so.5.9.0:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Core.so.5.9.0:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Core.so.5.9.0:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Core.so.5.9.0:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Core.so.5.9.0:(*IND*+0x0): multiple definition of `_end'
//usr/lib64/libQt5X11Extras.so.5:(*IND*+0x0): multiple definition of `__bss_start'
//usr/lib64/libQt5X11Extras.so.5:(*IND*+0x0): multiple definition of `_end'
//usr/lib64/libQt5X11Extras.so.5:(*IND*+0x0): multiple definition of `_edata'
//usr/lib64/libQt5PrintSupport.so.5:(*IND*+0x0): multiple definition of `_end'
//usr/lib64/libQt5PrintSupport.so.5:(*IND*+0x0): multiple definition of `_edata'
//usr/lib64/libQt5PrintSupport.so.5:(*IND*+0x0): multiple definition of `__bss_start'
//usr/lib64/libQt5Svg.so.5:(*IND*+0x0): multiple definition of `_end'
//usr/lib64/libQt5Svg.so.5:(*IND*+0x0): multiple definition of `_edata'
//usr/lib64/libQt5Svg.so.5:(*IND*+0x0): multiple definition of `__bss_start'
collect2: error: ld returned 1 exit status


I suspect this is related to upstream issue reported,
https://sourceware.org/bugzilla/show_bug.cgi?id=21074

Comment 1 Rex Dieter 2017-06-02 14:59:23 UTC
Added workaround to Qt5 stack to avoid use of gold until this is sorted out:

https://src.fedoraproject.org/cgit/rpms/qt5-qtbase.git/commit/?id=8b64b2c9321d3fd93065a40c91b1cb2545db9596

Comment 2 Nick Clifton 2017-06-05 14:29:14 UTC
FYI, the patch referred to in comment #10 of BZ 21074 *is* already in the rawhide sources.  So that is not the answer.

Comment 3 Nick Clifton 2017-06-09 08:57:52 UTC
Hi Reax,

I am still waiting for the GOLD linker maintainers to fix this patch upstream.  In the meantime however I have added a patch to the bfd linker so that it will no longer complain about the duplicate symbols.  Please try:

  binutils-2.28-8.fc27

Cheers
  Nick

Comment 4 Jan Kurik 2017-08-15 07:51:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 5 Robert-André Mauchin 🐧 2018-03-07 11:25:52 UTC
I'm experiencing similar issue while building Orion, a QT based Twitch client:

g++ -Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-rpath-link,/usr/lib64 -o orion main.o channelmanager.o channel.o fileutils.o networkmanager.o game.o jsonparser.o channellistmodel.o gamelistmodel.o runguard.o vod.o vodlistmodel.o vodmanager.o ircchat.o imageprovider.o badgeimageprovider.o badgecontainer.o viewersmodel.o settingsmanager.o httpserver.o power.o notificationmanager.o notificationsender.o qrc_qml.o moc_channel.o moc_channelmanager.o moc_networkmanager.o moc_game.o moc_channellistmodel.o moc_gamelistmodel.o moc_runguard.o moc_vodlistmodel.o moc_vodmanager.o moc_ircchat.o moc_imageprovider.o moc_httpserver.o moc_badgeimageprovider.o moc_badgecontainer.o moc_viewersmodel.o moc_settingsmanager.o moc_power.o moc_notificationmanager.o moc_notificationsender.o   -lQt5Widgets -lQt5QuickControls2 -lQt5Quick -lQt5Multimedia -lQt5Gui -lQt5Qml -lQt5Network -lQt5DBus -lQt5Core -lGL -lpthread 
/usr/lib64/libQt5QuickTemplates2.so.5:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5QuickTemplates2.so.5:(*IND*+0x0): multiple definition of `__bss_start'
collect2: error: ld returned 1 exit status

It doesn't work in Rawhide and F28. Any help?

Comment 6 Robert-André Mauchin 🐧 2018-03-07 12:11:32 UTC
Upstream bug: https://bugreports.qt.io/browse/QTBUG-65071

I solved it by passing "QMAKE_LFLAGS+=-fuse-ld=gold"

Comment 7 Nick Clifton 2018-03-07 14:08:05 UTC
Hi Robert-André,

  Ah - sorry - this wass my mistake.  I failed to copy the patch I created
  for F27 into the sources for F28 and rawhide.  (I had thought that the
  problem had been fixed in the newer upstream FSF sources, but this turns
  out to not be true).

  I have now applied the patch, so please try either binutils-2.29.1-21.fc28
  or binutils-2.30-8.fc29.

Cheers
  Nick

Comment 8 Rex Dieter 2018-03-23 19:15:38 UTC
I see no updates submitted for f28 yet at least, latest there is still binutils-2.29.1-20.fc28

Comment 9 Rex Dieter 2018-03-23 19:17:07 UTC
I did test that binutils-2.29.1-23.fc28 (latest f28 build) works as advertised, thanks.

Comment 10 Rex Dieter 2018-04-12 17:42:24 UTC
ping, no f28 updates submitted yet , so default f28 builds are (still) seeing failures

Comment 11 Rex Dieter 2018-04-12 17:42:55 UTC
*** Bug 1566073 has been marked as a duplicate of this bug. ***

Comment 12 Pier Luigi Fiorini 2018-04-27 08:06:09 UTC
How come the update has not been submitted yet despite Fedora 28 release being imminent?

Comment 13 Fedora Update System 2018-04-27 11:28:51 UTC
binutils-2.29.1-23.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ddd80a6dbb

Comment 14 Fedora Update System 2018-04-28 04:07:41 UTC
binutils-2.29.1-23.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ddd80a6dbb

Comment 15 Fedora Update System 2018-05-05 20:33:40 UTC
binutils-2.29.1-23.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.