Bug 1566082

Summary: unable to mount nfs-ganesha file server in ipv6 containerized cluster
Product: Red Hat Ceph Storage Reporter: subhash <vpoliset>
Component: RGWAssignee: Daniel Gryniewicz <dang>
Status: CLOSED ERRATA QA Contact: Sidhant Agrawal <sagrawal>
Severity: high Docs Contact: Bara Ancincova <bancinco>
Priority: high    
Version: 3.0CC: cbodley, ceph-eng-bugs, dang, edonnell, evelu, gabrioux, gmeno, hnallurv, kbader, kdreyer, mbenjamin, pasik, rperiyas, sweil, tserlin, vpoliset
Target Milestone: rc   
Target Release: 3.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: nfs-ganesha-2.7.1-1.el7cp Ubuntu: nfs-ganesha_2.7.1-3redhat1 Doc Type: Bug Fix
Doc Text:
.Mounting the NFS Ganesha file server in a containerized IPv6 cluster no longer fails When a containerized IPv6 Red Hat Ceph Storage cluster with an `nfs-ganesha-rgw` daemon was deployed by using the `ceph-ansible` utility, an attempt to mount the NFS Ganesha file server on a client failed with the `Connection Refused` error. Consequently, I/O requests were unable to run. This update fixes the default configuration IPv6 connections, and mounting the NFS Ganesha server works as expected in this case.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-03 19:01:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1593000    
Bug Blocks: 1557269, 1629656    

Comment 5 S├ębastien Han 2018-04-16 14:49:01 UTC
How can we know if it's a Ganesha issue or an issue on our side? Does Ganesha support IPV6? Does this work on non-container env?

Thanks.

Comment 6 subhash 2018-04-18 09:01:06 UTC
Hi

Yes Ganesha is supported with ipv6.It was tested on RHEL(ipv6) in non-container env and it worked fine.But it was tested manually during 3.0 i.e without deploying through ceph-ansible.And also this is the first time nfs-ganesha-rgw is is being tested on ipv6 container env.

Additional info: In ipv4 containerized cluster deployed through ceph-ansible i was able to mount nfs-ganesha.

Thanks

Comment 9 Guillaume Abrioux 2018-09-12 12:43:22 UTC
After discussed with Daniel Gryniewicz, it looks like it's a ganesha bug.
Changing component to nfs-ganesha

Comment 12 Ken Dreyer (Red Hat) 2018-10-02 16:49:51 UTC
9a2dd014d "Fix default config IPv6 connections" is in nfs-ganesha V2.7.0.1, so we'll fix this as part of the rebase in bz 1593000

Comment 17 Daniel Gryniewicz 2018-11-13 19:58:09 UTC
Looks good to me.

Comment 20 errata-xmlrpc 2019-01-03 19:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020