Bug 1567597

Summary: Introspection from the UI fails with: Unexpected token u in JSON at position 0
Product: Red Hat OpenStack Reporter: Udi <ukalifon>
Component: openstack-tripleo-uiAssignee: Jiri Tomasek <jtomasek>
Status: CLOSED ERRATA QA Contact: Udi <ukalifon>
Severity: urgent Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: augol, jjoyce, jrist, jschluet, slinaber, tvignaud
Target Milestone: betaKeywords: Triaged
Target Release: 14.0 (Rocky)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch.rpm Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-11 11:49:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Udi 2018-04-15 08:51:07 UTC
Description of problem:
Introspection in OSP13 on a virtual setup results with numerous toast error messages on the screen:

Nodes could not be loaded
Unexpected token u in JSON at position 0

In the browser console you see:

tripleo_ui.js:sourcemap:77 TypeError: e.message.filter is not a function
    at tripleo_ui.js:sourcemap:25
    at tripleo_ui.js:sourcemap:89
    at dispatch (tripleo_ui.js:sourcemap:45)
    at tripleo_ui.js:sourcemap:32
    at tripleo_ui.js:sourcemap:89
    at dispatch (tripleo_ui.js:sourcemap:45)
    at WebSocket.t.socket.onmessage (tripleo_ui.js:sourcemap:28)

Introspection is also failing from the command line. It seems like the GUI isn't handling the failures and throws syntax error exceptions. From the CLI the errors look like this:

Error has occurred while handling request for http://192.168.24.3:6385/v1/nodes/863b2849-d053-4599-a102-4c30dc83b670/ports/detail: ('Connection aborted.', BadStatusLine("''",))

Failed to power on the node, check it's power management configuration: %s


Version-Release number of selected component (if applicable):
openstack-ironic-inspector-7.2.1-0.20180302142656.397a98a.el7ost.noarch
openstack-ironic-common-10.1.2-0.20180326121311.ef08927.el7ost.noarch
openstack-ironic-conductor-10.1.2-0.20180326121311.ef08927.el7ost.noarch
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Start introspection

Comment 1 Jason E. Rist 2018-04-25 14:54:07 UTC
This should be fixed as part of config-download patches

Comment 4 Udi 2018-11-12 07:42:14 UTC
Verified: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

Comment 6 errata-xmlrpc 2019-01-11 11:49:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045