Bug 1567597 - Introspection from the UI fails with: Unexpected token u in JSON at position 0
Summary: Introspection from the UI fails with: Unexpected token u in JSON at position 0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: beta
: 14.0 (Rocky)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 08:51 UTC by Udi
Modified: 2019-01-11 11:49 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:49:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 564502 0 None None None 2018-04-26 13:24:21 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:53 UTC

Description Udi 2018-04-15 08:51:07 UTC
Description of problem:
Introspection in OSP13 on a virtual setup results with numerous toast error messages on the screen:

Nodes could not be loaded
Unexpected token u in JSON at position 0

In the browser console you see:

tripleo_ui.js:sourcemap:77 TypeError: e.message.filter is not a function
    at tripleo_ui.js:sourcemap:25
    at tripleo_ui.js:sourcemap:89
    at dispatch (tripleo_ui.js:sourcemap:45)
    at tripleo_ui.js:sourcemap:32
    at tripleo_ui.js:sourcemap:89
    at dispatch (tripleo_ui.js:sourcemap:45)
    at WebSocket.t.socket.onmessage (tripleo_ui.js:sourcemap:28)

Introspection is also failing from the command line. It seems like the GUI isn't handling the failures and throws syntax error exceptions. From the CLI the errors look like this:

Error has occurred while handling request for http://192.168.24.3:6385/v1/nodes/863b2849-d053-4599-a102-4c30dc83b670/ports/detail: ('Connection aborted.', BadStatusLine("''",))

Failed to power on the node, check it's power management configuration: %s


Version-Release number of selected component (if applicable):
openstack-ironic-inspector-7.2.1-0.20180302142656.397a98a.el7ost.noarch
openstack-ironic-common-10.1.2-0.20180326121311.ef08927.el7ost.noarch
openstack-ironic-conductor-10.1.2-0.20180326121311.ef08927.el7ost.noarch
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Start introspection

Comment 1 Jason E. Rist 2018-04-25 14:54:07 UTC
This should be fixed as part of config-download patches

Comment 4 Udi 2018-11-12 07:42:14 UTC
Verified: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

Comment 6 errata-xmlrpc 2019-01-11 11:49:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.