Bug 1571653

Summary: Block VLAN tenant networks for OVN driver from TripleO/Director
Product: Red Hat OpenStack Reporter: anil venkata <vkommadi>
Component: openstack-tripleo-heat-templatesAssignee: anil venkata <vkommadi>
Status: CLOSED ERRATA QA Contact: Eran Kuris <ekuris>
Severity: medium Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: amuller, dalvarez, dsneddon, jjoyce, mburns
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.2-7.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:53:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1561880    
Bug Blocks:    

Description anil venkata 2018-04-25 09:47:31 UTC
Description of problem:

VLAN tenant network does not work with OVN driver as expected. Currently below bugs are reported by QE team in bugzilla for this. In DFG-networking team meeting, it is decided that we should block vlan tenant networks from tripleO till all RHBZ fixed and a documentation bug also reported for adding this limitation. 

Bug 1570834 - OVN limitations when using VLAN tenant/provider networks
Bug 1561880 - OVN does not work with VLAN tenant network as expected
Bug 1566050 - OVN-DVR: SNAT traffic going through the compute cause router scheduled on compute node

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 7 Eran Kuris 2018-05-03 05:15:19 UTC
Fix verified on OSP13- puddle=2018-05-01.6
[stack@undercloud-0 ~]$ rpm -qa | grep openstack-tripleo-heat-templates-8
openstack-tripleo-heat-templates-8.0.2-9.el7ost.noarch
When setting VLAN as tenant network the deployment failed with error:

eter \'NeutronNetworkType\' is invalid: Invalid default vlan ("[u\'vlan\']" is not an allowed value [geneve])',
u'status': u'FAILED'}

Comment 12 errata-xmlrpc 2018-06-27 13:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086