Bug 1571653 - Block VLAN tenant networks for OVN driver from TripleO/Director
Summary: Block VLAN tenant networks for OVN driver from TripleO/Director
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: anil venkata
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On: 1561880
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 09:47 UTC by anil venkata
Modified: 2018-10-02 19:19 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:53:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 564425 None MERGED Restrict tenant network to geneve 2020-06-29 07:35:38 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:55:00 UTC

Description anil venkata 2018-04-25 09:47:31 UTC
Description of problem:

VLAN tenant network does not work with OVN driver as expected. Currently below bugs are reported by QE team in bugzilla for this. In DFG-networking team meeting, it is decided that we should block vlan tenant networks from tripleO till all RHBZ fixed and a documentation bug also reported for adding this limitation. 

Bug 1570834 - OVN limitations when using VLAN tenant/provider networks
Bug 1561880 - OVN does not work with VLAN tenant network as expected
Bug 1566050 - OVN-DVR: SNAT traffic going through the compute cause router scheduled on compute node

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 7 Eran Kuris 2018-05-03 05:15:19 UTC
Fix verified on OSP13- puddle=2018-05-01.6
[stack@undercloud-0 ~]$ rpm -qa | grep openstack-tripleo-heat-templates-8
openstack-tripleo-heat-templates-8.0.2-9.el7ost.noarch
When setting VLAN as tenant network the deployment failed with error:

eter \'NeutronNetworkType\' is invalid: Invalid default vlan ("[u\'vlan\']" is not an allowed value [geneve])',
u'status': u'FAILED'}

Comment 12 errata-xmlrpc 2018-06-27 13:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.