Bug 1571876

Summary: [Regression] Unable to adjust backlight with kernel 4.15 on Dell L421X (XPS 14)
Product: [Fedora] Fedora Reporter: Alessandro Guido <ag>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 27CC: airlied, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jcline, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-25 16:18:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alessandro Guido 2018-04-25 15:03:51 UTC
With kernel version 4.15 it is impossible to adjust the display backlight. Booting the same system with kernel 4.13 gives a working backlight out-of-the-box.

By looking inside "/sys/class/backlight" I can see that "acpi_video0" backlight module is not registered anymore on 4.15. The "intel_backlight" is present both in 4.13 and 4.15 but it hasn't ever worked.

I tried setting acpi_backlight to any of "video", "vendor", "native", "none" with no effects.

Comment 1 Jeremy Cline 2018-04-25 16:18:10 UTC
Hi Alessandro,

Can you test the 4.16.4 kernel update[0]? It should fix this.

[0] https://bodhi.fedoraproject.org/updates/FEDORA-2018-e71875c4aa

*** This bug has been marked as a duplicate of bug 1571036 ***