Bug 1571036 - Kernel updates breaks screen brightness keys
Summary: Kernel updates breaks screen brightness keys
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1570414 1571876 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 01:55 UTC by laolux
Modified: 2018-05-11 17:45 UTC (History)
19 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-27 23:07:17 UTC


Attachments (Terms of Use)

Description laolux 2018-04-24 01:55:40 UTC
Description of problem:
With newer kernels, namely 4.15.17-300.fc27.x86_64 and 4.16.3-200.fc27.x86_64 the keys to change the brightness of my laptop screen do not work any more. Booting older kernels like 4.15.16-300.fc27.x86_64 or before, the brightness keys do work. So it must be a regression with a recent kernel update.

Version-Release number of selected component (if applicable):
4.15.17-300.fc27.x86_64
4.16.3-200.fc27.x86_64

How reproducible:
Reproducible every time. When I select a new kernel in grub, then the brightness keys never work. When I select an old kernel in grub, then the brightness keys always work.

Steps to Reproduce:
1. Boot computer with new kernel
2. Login
3. Try the keyboard keys to increase/decrease screen brightness

Actual results:
Nothing happens, screen brightness stays fixed.

Expected results:
Screen gets brighter/darker.

Additional info:
Laptop is about 5 years old, MSI, Intel Core i7-3630QM. Never had an issue with the screen brightness in old versions of fedora.
This issue severely impacts battery life and the possibility to work in very bright/dark environments.

Comment 1 Jeremy Cline 2018-04-24 18:58:04 UTC
Hi,

Thanks for the bug report. One commit that jumped out at me between 4.15.16 and 4.15.17 is 965736ee654db8bb009a9736e52cac0278a24a8b. If you boot 4.15.17 with "video.only_lcd=0" added to the kernel command line, does that make any difference?

What's the output of "ls /sys/class/backlight"?

Comment 2 Hans de Goede 2018-04-24 19:05:35 UTC
Hi,

(In reply to Jeremy Cline from comment #1)
> Hi,
> 
> Thanks for the bug report. One commit that jumped out at me between 4.15.16
> and 4.15.17 is 965736ee654db8bb009a9736e52cac0278a24a8b. If you boot 4.15.17
> with "video.only_lcd=0" added to the kernel command line, does that make any
> difference?

Oh, good call Jeremy in case you've not seen it yet, here is a commit which
should fix the regressions caused by that commit:

https://patchwork.kernel.org/patch/10345845/

Perhaps we should add this to the Fedora kernel while it finds it way upstream?

> What's the output of "ls /sys/class/backlight"?

If "video.only_lcd=0" helps then it likely is empty without that kernel argument. Laolux can you confirm this?

Regards,

Hans

Comment 3 Jeremy Cline 2018-04-24 19:17:04 UTC
(In reply to Hans de Goede from comment #2)
> Hi,
> 
> (In reply to Jeremy Cline from comment #1)
> > Hi,
> > 
> > Thanks for the bug report. One commit that jumped out at me between 4.15.16
> > and 4.15.17 is 965736ee654db8bb009a9736e52cac0278a24a8b. If you boot 4.15.17
> > with "video.only_lcd=0" added to the kernel command line, does that make any
> > difference?
> 
> Oh, good call Jeremy in case you've not seen it yet, here is a commit which
> should fix the regressions caused by that commit:
> 
> https://patchwork.kernel.org/patch/10345845/
> 
> Perhaps we should add this to the Fedora kernel while it finds it way
> upstream?

Ah, I hadn't seen that, thanks! I'll see about including it with the v4.16.4 update once I sort out the build failures.

Comment 4 Jeremy Cline 2018-04-24 22:02:31 UTC
*** Bug 1570414 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2018-04-25 13:26:09 UTC
kernel-4.16.4-300.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5926c0ffc8

Comment 6 Fedora Update System 2018-04-25 13:26:35 UTC
kernel-4.16.4-200.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e71875c4aa

Comment 7 Jeremy Cline 2018-04-25 13:39:43 UTC
Laolux, Oswaldo,

In addition to seeing if "video.only_lcd=0" helps, can you both also test the 4.16.4 update and let us know if that works? Assuming 965736ee654db is the root cause, it should fix things for you, but there's a non-zero chance additional tweaking will be required depending on your hardware.

Thanks!

Comment 8 laolux 2018-04-25 15:17:17 UTC
Problem solved.

Using 4.15.17, "ls /sys/class/backlight" outputs nothing.
Adding "video.only_lcd=0" repairs the brightness adjustment with the keyboard keys for both, 4.15.17 and 4.16.3. It also changes the output of "ls /sys/class/backlight" to
acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0

Kernel 4.16.4 completely fixes the problem, as "video.only_lcd=0" is no longer needed.

Thanks a lot!

Comment 9 Jeremy Cline 2018-04-25 16:18:10 UTC
*** Bug 1571876 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2018-04-26 04:53:08 UTC
kernel-4.16.4-300.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5926c0ffc8

Comment 11 Fedora Update System 2018-04-26 13:10:12 UTC
kernel-4.16.4-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 12 Fedora Update System 2018-04-27 07:14:28 UTC
kernel-4.16.4-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 13 Fedora Update System 2018-04-27 07:54:22 UTC
kernel-4.16.4-200.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e71875c4aa

Comment 14 Fedora Update System 2018-04-27 23:07:17 UTC
kernel-4.16.4-300.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-04-28 16:15:39 UTC
kernel-4.16.5-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 16 Fedora Update System 2018-04-29 05:15:26 UTC
kernel-4.16.4-200.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-05-01 14:59:48 UTC
kernel-4.16.6-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 18 Fedora Update System 2018-05-02 09:51:48 UTC
kernel-4.16.6-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 19 Fedora Update System 2018-05-03 12:33:39 UTC
kernel-4.16.7-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 20 Fedora Update System 2018-05-06 05:34:01 UTC
kernel-4.16.7-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 21 Fedora Update System 2018-05-11 17:45:20 UTC
kernel-4.16.7-100.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.