Bug 1573605

Summary: hangs on reboot or shutdown when nfs filesystem mounted
Product: Red Hat Enterprise Linux 7 Reporter: jas
Component: systemdAssignee: systemd-maint
Status: CLOSED DUPLICATE QA Contact: qe-baseos-daemons
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.4CC: ddouwsma, dtardon, hannsj_uhl, systemd-maint-list
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-22 12:14:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jas 2018-05-01 18:49:44 UTC
When my system is rebooted with NFS filesystems mounted, it hangs for around 10-15 minutes (sometimes more) before it will reboot.  I can see that this particular issue has been opened multiple times (eg. bug # 1312002).  It has been marked as resolved.  I'm running Kernel 3.10.0-693.21.1.el7.x86_64, and I've upgraded to systemd-219-57.el7 which claims to resolve this issue.  However, after installing the systemd update, and issuing a reboot, there is no change.  For example, I see:

systemd-shutdown: Unmounting file systems.
systemd-shutdown: Remounting '/eecs/home' read-only with options fd=-1,pgrp=1723,timeout=300,minproto=5,maxproto=5,indirect,pipe_ino=-1
systemd-shutdown: Unmounting /eecs/home [Why is this mounted read only then unmounted?]
systemd-shutdown: Unmounting /eecs.
nfs: server sea not responding, still trying
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out

I was using autofs as well, but to ensure that autofs has nothing to do with this problem, I disabled autofs.  It didn't make any difference.

How can I provide additional information in order to assist with resolving this issue?

Comment 2 David Tardon 2018-06-22 12:14:53 UTC

*** This bug has been marked as a duplicate of bug 1571098 ***

Comment 3 Donald Douwsma 2018-08-25 02:19:13 UTC
Note: bug 1571098 is tracking the RHEL-7.6 release. A zstream bug was cloned for a fix in RHEL-7.5 and closed as errata https://access.redhat.com/errata/RHBA-2018:2447 (systemd-219-57.el7_5.1)