Bug 1573605 - hangs on reboot or shutdown when nfs filesystem mounted
Summary: hangs on reboot or shutdown when nfs filesystem mounted
Keywords:
Status: CLOSED DUPLICATE of bug 1571098
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 18:49 UTC by jas
Modified: 2018-09-11 14:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-22 12:14:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1312002 None CLOSED hangs on reboot or shutdown when nfs file system mounted 2019-07-04 05:20:02 UTC

Description jas 2018-05-01 18:49:44 UTC
When my system is rebooted with NFS filesystems mounted, it hangs for around 10-15 minutes (sometimes more) before it will reboot.  I can see that this particular issue has been opened multiple times (eg. bug # 1312002).  It has been marked as resolved.  I'm running Kernel 3.10.0-693.21.1.el7.x86_64, and I've upgraded to systemd-219-57.el7 which claims to resolve this issue.  However, after installing the systemd update, and issuing a reboot, there is no change.  For example, I see:

systemd-shutdown: Unmounting file systems.
systemd-shutdown: Remounting '/eecs/home' read-only with options fd=-1,pgrp=1723,timeout=300,minproto=5,maxproto=5,indirect,pipe_ino=-1
systemd-shutdown: Unmounting /eecs/home [Why is this mounted read only then unmounted?]
systemd-shutdown: Unmounting /eecs.
nfs: server sea not responding, still trying
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out
nfs: server sea not responding, timed out

I was using autofs as well, but to ensure that autofs has nothing to do with this problem, I disabled autofs.  It didn't make any difference.

How can I provide additional information in order to assist with resolving this issue?

Comment 2 David Tardon 2018-06-22 12:14:53 UTC

*** This bug has been marked as a duplicate of bug 1571098 ***

Comment 3 Donald Douwsma 2018-08-25 02:19:13 UTC
Note: bug 1571098 is tracking the RHEL-7.6 release. A zstream bug was cloned for a fix in RHEL-7.5 and closed as errata https://access.redhat.com/errata/RHBA-2018:2447 (systemd-219-57.el7_5.1)


Note You need to log in before you can comment on or make changes to this bug.