Bug 1577007

Summary: Xorg server dumps core instead of starting a session
Product: [Fedora] Fedora Reporter: Michal Jaegermann <michal.jnn>
Component: xorg-x11-serverAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: alexl, bskeggs, caillon+fedoraproject, hdegoede, jglisse, john.j5live, ofourdan, rhughes, rstrode, sandmann, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-02 18:07:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
core from Xserver crash left in /var/lib/systemd/coredump/ none

Description Michal Jaegermann 2018-05-11 01:02:58 UTC
Created attachment 1434631 [details]
core from Xserver crash left in /var/lib/systemd/coredump/

Description of problem:

An attempt to start a Gnome session (_not_ under wayland) ends up with crashed X server.  An excerpt from journal looks roughly like this:

 09:55:38  gsd-keyboard[1000]: gsd-keyboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
 09:55:39  gsd-color[1438]: failed to connect to device: Failed to connect to missing device /org/freedesktop/ColorManager/devices/xrandr_Seiko_Epson_Corporation_gdm_42
 09:55:40  gnome-session[882]: gnome-session-binary[882]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
 09:55:40  gnome-session-binary[882]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
 09:55:40  gnome-shell[1655]: pushModal: invocation of begin_modal failed
 09:55:40  gnome-session[882]: gnome-session-binary[882]: WARNING: App 'org.gnome.SettingsDaemon.Color.desktop' exited with code 1
 09:55:40  gnome-session-binary[882]: WARNING: App 'org.gnome.SettingsDaemon.Color.desktop' exited with code 1
 09:55:40  gnome-shell[1655]: pushModal: invocation of begin_modal failed
 09:55:40  gnome-session[882]: gnome-session-binary[882]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
 09:55:40  gnome-session-binary[882]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
 09:55:40  gnome-shell[904]: gnome-shell: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
 09:55:40  audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@1-5992-0 comm="systemd" exe="/usr/lib/systemd/systemd" h
 09:55:40  systemd-coredump[6010]: Process 868 (Xorg) of user 42 dumped core.
                                                         
      Stack trace of thread 868:
      #0  0x00007f6673e02bde n/a (ld-linux-x86-64.so.2)
      #1  0x00000000023a50c0 n/a (n/a)
-- Subject: Process 868 (Xorg) dumped core

gdb reports "Program terminated with signal SIGBUS, Bus error".

Version-Release number of selected component (if applicable):
xorg-x11-server-1.19.6-7.fc27

How reproducible:
Happens unpredictably (not only with this version)

Additional info:
This time systemd-coredump catches the core and lz4 compressed file is reasonably small so it is attached.

No idea from where "Seiko_Epson_Corporation" is coming from.  This is from ASUS K52Jc with Intel graphics.

Comment 1 Jan Kurik 2018-08-14 10:03:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Hans de Goede 2018-09-02 18:07:50 UTC
I believe that this is a mesa issue which is fixed by this commit:

https://cgit.freedesktop.org/mesa/mesa/commit/?id=9baff597ce021f7691187b0d1d1bbc16d07b13e1

I'm currently working on doing a mesa build for f29 which includes this fix, the mesa problem which is the root cause of the Xorg crash is being tracked in bug 1575328, I'm marking this bug as a duplicate of that.

*** This bug has been marked as a duplicate of bug 1575328 ***