Bug 1575328 - Xorg crashes after latest mesa update
Summary: Xorg crashes after latest mesa update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1577007 1593885 (view as bug list)
Depends On:
Blocks: F29BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-05-06 01:12 UTC by Filipe Rosset
Modified: 2018-09-10 15:58 UTC (History)
26 users (show)

Fixed In Version: mesa-18.2.0~rc5-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-10 15:58:23 UTC


Attachments (Terms of Use)
Xorg crash after glibc upgrade (118.00 KB, application/x-gzip)
2018-05-06 01:12 UTC, Filipe Rosset
no flags Details

Description Filipe Rosset 2018-05-06 01:12:53 UTC
Created attachment 1432199 [details]
Xorg crash after glibc upgrade

please see attached logs.


[root@raw ~]# rpm -qi xorg-x11-server-Xorg
Name        : xorg-x11-server-Xorg
Version     : 1.19.99.905
Release     : 2.fc29
Architecture: x86_64
Install Date: sáb 28 abr 2018 17:16:58 -03
Group       : User Interface/X
Size        : 3825522
License     : MIT
Signature   : RSA/SHA256, qua 25 abr 2018 13:10:47 -03, Key ID a20aa56b429476b4
Source RPM  : xorg-x11-server-1.19.99.905-2.fc29.src.rpm
Build Date  : qua 25 abr 2018 12:53:37 -03
Build Host  : buildhw-09.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.x.org
Bug URL     : https://bugz.fedoraproject.org/xorg-x11-server
Summary     : Xorg X server
Description :
X.org X11 is an open source implementation of the X Window System.  It
provides the basic low level functionality which full fledged
graphical user interfaces (GUIs) such as GNOME and KDE are designed
upon.
[root@raw ~]# rpm -qi glibc
Name        : glibc
Version     : 2.27.9000
Release     : 16.fc29
Architecture: x86_64
Install Date: sáb 05 mai 2018 20:01:04 -03
Group       : Unspecified
Size        : 13384582
License     : LGPLv2+ and LGPLv2+ with exceptions and GPLv2+
Signature   : RSA/SHA256, sex 04 mai 2018 11:48:16 -03, Key ID a20aa56b429476b4
Source RPM  : glibc-2.27.9000-16.fc29.src.rpm
Build Date  : sex 04 mai 2018 09:56:20 -03
Build Host  : buildvm-14.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.gnu.org/software/glibc/
Bug URL     : https://bugz.fedoraproject.org/glibc
Summary     : The GNU libc libraries
Description :
The glibc package contains standard libraries which are used by
multiple programs on the system. In order to save disk space and
memory, as well as to make upgrading easier, common system code is
kept in one place and shared between programs. This particular package
contains the most important sets of shared libraries: the standard C
library and the standard math library. Without these two libraries, a
Linux system will not function.
[root@raw ~]#

Comment 1 Filipe Rosset 2018-05-06 01:17:07 UTC
Xorg keeps crashing, then abrtd / systemd core dumps will generate a lot of files and then disk is full.

For now I disabled abrtd and renamed my sddm to avoid sddm attempts to start Xorg

Xorg is unusable in rawhide at this moment (my setup is Xorg + SDDM + Xfce), so now I have a VM without graphic mode.

Let me know if you need additional information to debug this crash.

Comment 2 Carlos O'Donell 2018-05-06 01:39:36 UTC
(In reply to Filipe Rosset from comment #1)
> Xorg keeps crashing, then abrtd / systemd core dumps will generate a lot of
> files and then disk is full.
> 
> For now I disabled abrtd and renamed my sddm to avoid sddm attempts to start
> Xorg
> 
> Xorg is unusable in rawhide at this moment (my setup is Xorg + SDDM + Xfce),
> so now I have a VM without graphic mode.
> 
> Let me know if you need additional information to debug this crash.

If you downgrade glibc does it start working again?

Comment 3 Filipe Rosset 2018-05-06 11:03:26 UTC
Sorry about the confusion, the culprit is not glibc but mesa.

Latest working packages on rawhide:
[filiperosset@raw ~]$ rpm -qa | grep mesa | sort
mesa-dri-drivers-18.0.2-1.fc29.x86_64
mesa-filesystem-18.0.2-1.fc29.x86_64
mesa-libEGL-18.0.2-1.fc29.x86_64
mesa-libEGL-devel-18.0.2-1.fc29.x86_64
mesa-libgbm-18.0.2-1.fc29.x86_64
mesa-libGL-18.0.2-1.fc29.x86_64
mesa-libglapi-18.0.2-1.fc29.x86_64
mesa-libGL-devel-18.0.2-1.fc29.x86_64
mesa-libOpenCL-18.0.2-1.fc29.x86_64
mesa-libxatracker-18.0.2-1.fc29.x86_6


Broken ones:
- Update to 18.1.0~rc3
https://koji.fedoraproject.org/koji/buildinfo?buildID=1079519

- Update to 18.1.0~rc2
https://koji.fedoraproject.org/koji/buildinfo?buildID=1079237

Comment 4 Jan Kurik 2018-08-14 10:25:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Hans de Goede 2018-09-02 17:32:04 UTC
Thank you for the bug report, I believe that this is fixed by:

https://cgit.freedesktop.org/mesa/mesa/commit/?id=9baff597ce021f7691187b0d1d1bbc16d07b13e1

Which is part of the upstream 8.2.0-rc5 release. I've started a build fixing this here: https://koji.fedoraproject.org/koji/buildinfo?buildID=1141289

I will push this to f29-updates-testing, referencing this bug when the build is finished.

Comment 6 Hans de Goede 2018-09-02 17:50:13 UTC
Note the build from the previous comment failed on armv7, this is a llvm issue which is fixed in rawhide, but not in F29. I've started a llvm build for F29 fixing this.

Comment 7 Hans de Goede 2018-09-02 18:07:48 UTC
*** Bug 1593885 has been marked as a duplicate of this bug. ***

Comment 8 Hans de Goede 2018-09-02 18:07:50 UTC
*** Bug 1577007 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-09-03 07:23:42 UTC
llvm-7.0.0-0.9.rc2.fc29 mesa-18.2.0~rc5-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e86f51109a

Comment 10 Hans de Goede 2018-09-03 07:40:17 UTC
I'm hereby proposing this bug as a beta freeze exception, rationale:

This bug causes Xorg to crash at startup on any hardware using glamor + gbm, which is not only virtualbox but e.g. also some laptops such as the ASUS K52Jc from bug 1577007.

The fix is rebasing mesa to a newer rc which contains a handful of fixes carefully cherry-picked by upstream, as such we are using the upstream fix here and not rolling our own.

Note that this also involves adding a newer llvm build as the one currently in F29 did not build the amdgpu backend on ARM causing mesa to fail to build.

Comment 11 Fedora Update System 2018-09-04 09:03:19 UTC
llvm-7.0.0-0.9.rc2.fc29, mesa-18.2.0~rc5-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e86f51109a

Comment 12 Filipe Rosset 2018-09-04 12:34:19 UTC
great, thanks, I'll test these updates this week.

Comment 13 Geoffrey Marr 2018-09-04 20:56:42 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as this fixes failure of X to start on some hardware, which is important and cannot be fixed with an update. We do note this fix involves significant change to critical components and should be carefully tested.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 14 Fedora Update System 2018-09-08 12:43:16 UTC
llvm-7.0.0-0.9.rc2.fc29 mesa-18.2.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e86f51109a

Comment 15 Fedora Update System 2018-09-08 16:11:27 UTC
llvm-7.0.0-0.9.rc2.fc29, mesa-18.2.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e86f51109a

Comment 16 Fedora Update System 2018-09-09 06:55:55 UTC
llvm-7.0.0-0.9.rc2.fc29 mesa-18.2.0~rc5-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e86f51109a

Comment 17 Fedora Update System 2018-09-09 20:22:52 UTC
llvm-7.0.0-0.9.rc2.fc29, mesa-18.2.0~rc5-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e86f51109a

Comment 18 Fedora Update System 2018-09-10 15:58:23 UTC
llvm-7.0.0-0.9.rc2.fc29, mesa-18.2.0~rc5-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.