Bug 1577982

Summary: FFU: undercloud upgrade fails with python-heat-tests and python-ironic-tests dependencies
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: python-ironic-tests-tempestAssignee: Jon Schlueter <jschluet>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: augol, dbecker, jamsmith, jschluet, mburns, mcornea, morazi, sclewis
Target Milestone: rcKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-ironic-tests-tempest-1.1.1-0.20180423155752.b50f6e0.el7ost python-heat-tests-tempest-0.1.1-0.20180418163701.07a6bd4.el7ost Doc Type: Bug Fix
Doc Text:
A tempest plugin (-tests) rpm installed before the upgrade fails after the OSP Release 13 upgrade. The initial upgrade packaging did not include the epoch commands needed to obsolete the old rpm. The sub-rpm is not shipped in OSP 13, and the Obsoletes in the new plugin rpm didn't correctly Obsolete the right rpm. To fix the issue, correct the obsoletes or manually uninstall the old -rpm and manually install the replacement plugin python2-*-tests-tempest.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:56:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marius Cornea 2018-05-14 14:42:47 UTC
Description of problem:
When installing -tests packages before running going through the fast forward upgrade workflow the undercloud upgrade fails with:

2018-05-13 05:20:58,480 INFO: Error: Package: 1:python-heat-tests-9.0.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,480 INFO:            Requires: openstack-heat-common = 1:9.0.3-1.el7ost
2018-05-13 05:20:58,480 INFO:            Removing: 1:openstack-heat-common-9.0.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,480 INFO:                openstack-heat-common = 1:9.0.3-1.el7ost
2018-05-13 05:20:58,480 INFO:            Updated By: 1:openstack-heat-common-10.0.1-0.20180411125639.825731d.el7ost.noarch (rhelosp-13.0-puddle)
2018-05-13 05:20:58,481 INFO:                openstack-heat-common = 1:10.0.1-0.20180411125639.825731d.el7ost
2018-05-13 05:20:58,483 INFO: Error: Package: 1:python-ironic-tests-9.1.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,483 INFO:            Requires: openstack-ironic-common = 1:9.1.3-1.el7ost
2018-05-13 05:20:58,483 INFO:            Removing: 1:openstack-ironic-common-9.1.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,483 INFO:                openstack-ironic-common = 1:9.1.3-1.el7ost
2018-05-13 05:20:58,483 INFO:            Updated By: 1:openstack-ironic-common-10.1.2-3.el7ost.noarch (rhelosp-13.0-puddle)
2018-05-13 05:20:58,484 INFO:                openstack-ironic-common = 1:10.1.2-3.el7ost
2018-05-13 05:20:58,484 INFO:  You could try using --skip-broken to work around the problem
2018-05-13 05:20:59,408 INFO:  You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 z4
2. Install -tests packages
3. Upgrade undercloud to 11/12/13

Actual results:
Upgrade fails with failed dependencies.

Expected results:
Upgrade succeeds.

Additional info:

Comment 13 errata-xmlrpc 2018-06-27 13:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086