Bug 1577982 - FFU: undercloud upgrade fails with python-heat-tests and python-ironic-tests dependencies
Summary: FFU: undercloud upgrade fails with python-heat-tests and python-ironic-tests ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ironic-tests-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Jon Schlueter
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-14 14:42 UTC by Marius Cornea
Modified: 2018-06-27 13:57 UTC (History)
8 users (show)

Fixed In Version: python-ironic-tests-tempest-1.1.1-0.20180423155752.b50f6e0.el7ost python-heat-tests-tempest-0.1.1-0.20180418163701.07a6bd4.el7ost
Doc Type: Bug Fix
Doc Text:
A tempest plugin (-tests) rpm installed before the upgrade fails after the OSP Release 13 upgrade. The initial upgrade packaging did not include the epoch commands needed to obsolete the old rpm. The sub-rpm is not shipped in OSP 13, and the Obsoletes in the new plugin rpm didn't correctly Obsolete the right rpm. To fix the issue, correct the obsoletes or manually uninstall the old -rpm and manually install the replacement plugin python2-*-tests-tempest.
Clone Of:
Environment:
Last Closed: 2018-06-27 13:56:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 13770 None rpm-master: MERGED openstack/heat-tempest-plugin-distgit: Use Epoch in obsoletes to fix upgrade issue of tempest plugin (I08ec3a3b7b730127b... 2018-05-14 15:42:57 UTC
RDO 13771 None rpm-master: MERGED openstack/ironic-tempest-plugin-distgit: Use Epoch in obsoletes to fix upgrade issue of tempest plugin (Ib8c62a0f243a189... 2018-05-14 15:42:51 UTC
RDO 133772 None None None 2018-05-14 15:38:59 UTC
RDO 133773 None None None 2018-05-14 15:43:15 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:57:37 UTC

Description Marius Cornea 2018-05-14 14:42:47 UTC
Description of problem:
When installing -tests packages before running going through the fast forward upgrade workflow the undercloud upgrade fails with:

2018-05-13 05:20:58,480 INFO: Error: Package: 1:python-heat-tests-9.0.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,480 INFO:            Requires: openstack-heat-common = 1:9.0.3-1.el7ost
2018-05-13 05:20:58,480 INFO:            Removing: 1:openstack-heat-common-9.0.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,480 INFO:                openstack-heat-common = 1:9.0.3-1.el7ost
2018-05-13 05:20:58,480 INFO:            Updated By: 1:openstack-heat-common-10.0.1-0.20180411125639.825731d.el7ost.noarch (rhelosp-13.0-puddle)
2018-05-13 05:20:58,481 INFO:                openstack-heat-common = 1:10.0.1-0.20180411125639.825731d.el7ost
2018-05-13 05:20:58,483 INFO: Error: Package: 1:python-ironic-tests-9.1.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,483 INFO:            Requires: openstack-ironic-common = 1:9.1.3-1.el7ost
2018-05-13 05:20:58,483 INFO:            Removing: 1:openstack-ironic-common-9.1.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
2018-05-13 05:20:58,483 INFO:                openstack-ironic-common = 1:9.1.3-1.el7ost
2018-05-13 05:20:58,483 INFO:            Updated By: 1:openstack-ironic-common-10.1.2-3.el7ost.noarch (rhelosp-13.0-puddle)
2018-05-13 05:20:58,484 INFO:                openstack-ironic-common = 1:10.1.2-3.el7ost
2018-05-13 05:20:58,484 INFO:  You could try using --skip-broken to work around the problem
2018-05-13 05:20:59,408 INFO:  You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 z4
2. Install -tests packages
3. Upgrade undercloud to 11/12/13

Actual results:
Upgrade fails with failed dependencies.

Expected results:
Upgrade succeeds.

Additional info:

Comment 13 errata-xmlrpc 2018-06-27 13:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.