Bug 1589490

Summary: Uninstallable due to missing dependencies
Product: [Fedora] Fedora EPEL Reporter: Anssi Johansson <rhbugs>
Component: bansheeAssignee: Moez Roy <moez.roy>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: chkr, claudiorodrigo, moez.roy, pokorra.mailinglists, tcallawa, tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-12 14:52:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Anssi Johansson 2018-06-10 06:30:04 UTC
Description of problem:
The old webkitgtk package which provided libwebkitgtk-1.0.so.0 and libjavascriptcoregtk-1.0.so.0 was recently removed from EPEL due to the package being unmaintained. This makes banshee uninstallable. Perhaps this package should use the newer webkitgtk3. banshee also requires libgpod-sharp >= 0.8.2, which is not available either. The latter missing requirement was already documented in bug 1406012.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. "yum install banshee"

Actual results:
--> Finished Dependency Resolution
Error: Package: banshee-2.6.2-11.el7.x86_64 (epel)
           Requires: libwebkitgtk-1.0.so.0()(64bit)
Error: Package: banshee-2.6.2-11.el7.x86_64 (epel)
           Requires: libjavascriptcoregtk-1.0.so.0()(64bit)
Error: Package: banshee-2.6.2-11.el7.x86_64 (epel)
           Requires: libgpod-sharp >= 0.8.2

Expected results:
Package gets installed

Additional info:

Comment 1 Troy Dawson 2019-04-12 14:52:14 UTC

*** This bug has been marked as a duplicate of bug 1647999 ***